Problem mit ClamAV, kein Scanning: HAVP und Dansguardian


  • Hallo zusammen,

    Ich habe meine lieben Probleme auf einer aktuellen 2.0.2 Installation, sowohl HAVP, als auch Dansguardian ans laufen zu bekommen.
    Alles scheint auf Probleme mit dem ClamAV zu deuten.

    Als erstes habe ich havp installiert. Bei dessen Installation ist ClamAV als dependency automatisch mit installiert worden. Fein.
    Doch dann zeigt mir der Log folgende Meldungen:

    Feb 16 22:44:40	havp[36891]: --- Initializing Clamd Socket Scanner
    Feb 16 22:44:40	havp[36891]: Running as user: havp, group: havp
    Feb 16 22:44:40	havp[36891]: === Mandatory locking disabled! KEEPBACK settings not used!
    Feb 16 22:44:40	havp[36891]: === Starting HAVP Version: 0.91
    ...
    Feb 16 22:45:40	havp[36891]: ERROR: Clamd Socket Scanner failed EICAR virus test! (Could not connect to scanner socket)
    Feb 16 22:45:40	havp[36891]: Clamd: Could not connect to scanner! Scanner down?
    

    Natürlich geht auch kein Traffic über den HAVP Proxy, es scheint alles am Scanner zu hängen. Aber was ist das Problem? Ich las von einigen Problemen mit der 2.0.1 Plattform und ClamAV, welche aber mit 2.0.2 alle behoben wurden.

    Ich habe in der Paketverwaltung Webinterface mehrfach sowohl GUI Komponenten als auch das Peket selbst neu installiert. Keine Änderung.
    Dann habe ich es komplett deinstalliert und Dansguardian eingesetzt: keine Änderung!

    Vielleicht kann mit jemand an dieser Stelle schon einen Tipp geben? :-)
    So, mein aktueller Ansatz ist es, einmal per Shell den ClamAV herunterzuwerfen, und seine Config zu entfernen. Danach wollte Ich ihn mit einer fischen Dansguardian-Installation (auto-dependency) wieder installieren und mal sehen, was passiert. Leider kenne Ich die Befehle von BSD nicht. Geläufig sind mir die Varianten IPKG und apt-get. Kann mit hier jemand unter die Arme greifen?

    Vielen Dank für eure Antworten.