Wireless tethering from phone using USB wireless on pfsense



  • How would you set this up? I want to be able to put my phone in wireless AP mode (tethering) and have pfsense connect to this automatically if the original WAN is down.

    I tried adding my USB support wireless card as OPT1 and messing with settings, but couldn't get this to work. It would be nice to have this set up for when my ISP internet is down for a bit.

    Thank you in advance.



  • @rekd0514:

    I tried adding my USB support wireless card as OPT1 and messing with settings, but couldn't get this to work.

    It would be helpful to have more detail than "couldn't get this to work". Couldn't get a working wireless link to your phone? Couldn't get pfSense to "fail over" to use the phone for Internet access?

    @rekd0514:

    It would be nice to have this set up for when my ISP internet is down for a bit.

    Will you need to access any of your "local" computers through the phone? If so you might need to discuss allocation of a public IP address with your phone company. (Some phone companies give private IP addresses to 3G clients.)



  • I guess I'm not exactly sure what steps I need to research to make it possible. I couldn't find anyone that had actually tried this by searching.

    Is adding OPT1 as an infrastructure network the place to start? How do I set this up since it is just connecting via wireless to another access point that is the modem. I was testing a lot of different setups with the main WAN disabled just to see if I could connect to the internet.

    All this would be used for is internet fail-over WAN to distribute throughout the house via the pfsense router.



  • I recently tried to do this myself. The main reason I stopped working on it was because my USB WiFi Adapter was causing pfSense to reboot at best every few hours. But I also was unable to get pfSense to properly connect to my phone. It would say it was connected (under Status -> Interfaces) but it wouldn't get an IP address and so of course, wouldn't actually work. I don't know if thats the issue you're having, but it might be worthwhile, after setting it up to connect, to see if its not connecting at all, or connecting but not getting an IP address.



  • @rekd0514:

    I guess I'm not exactly sure what steps I need to research to make it possible.

    1. Get pfSense to connect to phone
    2. Configure pfSense WAN failover.
    3. Test.

    @rekd0514:

    Is adding OPT1 as an infrastructure network the place to start?

    The pfSense wireless interface needs to be Infrastructure mode since it is  to connect to an Access Point and the interface Type should be set to DHCP since configuration information will be supplied by the AP. You will also need to configure the wireless network name (SSID) and compatible encryption parameters. The pfSense page Status -> Wireless will display nearby AP and their network names. On completion of configuration Enable the interface, Save and Apply. Then check on the pfSense page Status -> Interfaces that the wireless interface has been assigned an IP address. If it has you have successfully completed Step 1.

    Because of @ZGruk:

    The main reason I stopped working on it was because my USB WiFi Adapter was causing pfSense to reboot at best every few hours.

    it would probably be worth using a snapshot build of pfSense 2.1 so you have the most up to date device drivers.



  • I assume the SSID should be the name of the hotspot AP. Is that right? Also should the IP address assigned to the wireless interface be within my DHCP server range?



  • @rekd0514:

    I assume the SSID should be the name of the hotspot AP. Is that right?

    In pfSense the wireless interface SSID should be the WiFi network name configured in the hotspot. This might not be the same as the name of the hotspot AP.

    @rekd0514:

    Also should the IP address assigned to the wireless interface be within my DHCP server range?

    The pfSense interface type should be set to DHCP to get configuration information from the AP.


Log in to reply