PfSense über LAN nicht mehr zu erreichen



  • Hallo,

    ich habe es wohl geschafft pfSense 2 den Netzwerktot beizufügen und hoffe mir kann jemand helfen die Kuh wieder vom Eis zu bekommen, ohne alles komplett neu aufzusetzen.
    Die einzige Möglichkeit besteht also noch Änderungen direkt vorzunehmen, aber da komme ich mit meinen Linux und pfSense Grundkenntnissen nicht wirklich voran.

    Das ist passiert (alles über die GUI ausgeführt):
    pfSense hat zwei NICs, einmal intern mit DHCP konfiguriert (vr1 - 192.168.13.0/24) und dann für eine Breitbandverbindung über PPPoE (vr0).
    PPPoE funktionierte nicht mehr, daher habe ich versucht die beiden NICs neu zuzuweisen.
    Das hat auch soweit funktioniert, aber in der Dropdown für LAN1 stand bei Gateway nun nur der Eintrag "none" - ich bin recht sicher das es dort früher auch mal den Eintrag "GW_WAN" gab.

    Irgendwann stand dann auch unter "Interface" für WAN eine öffentliche IP "217.x.x.x", aber ein Zugriff auf das WAN war trotzdem nicht möglich.
    Also habe ich mir die Gateways angesehen und siehe da - dort war auch "GW_WAN" zu finden.
    Dort habe ich den Eintrag default Gateway aktiviert aber es war immer noch kein Zugriff zum WAN möglich.

    Und nun mein letzter Eingriff:
    Ich habe für "GW_WAN" auch eine Route eingeben, dort habe ich 192.168.13.0 / 24 eingetragen - und das war es dann.

    • Ist meine Vermutung richtig, dass ich nun bei jeden Zugriff auf pfSense (192.168.13.1) auf "GW_WAN" gerouted werde …?

    Es wäre super wenn mir jemand sagen kann wie ich denn letzten Eintrag wieder entfernen kann, so dass pfSense zumindest wieder über das Netz zu erreichen ist....

    Vielen Dank

    Andre



  • Auf die Gefahr, dass ich Blödsinn erzähle. Kannst du nicht direkt per Bildschirm und Tastatur auf deinen Router zugreifen und dort die IP´s für das Interface neu vergeben oder evt. einen Rest auf Standardeinstellungen vornehmen? Backup vorausgesetzt.



  • Hallo gekko,

    das stimmt, direkten Zugriff habe ich noch - das Einzige, was geblieben ist …
    Aber das mit dem Zurücksetzen der Einstellungen möchte ich vermeiden - da es leider kein Backup gibt und wir vor kurzem erst einige Tage eine neue VoIP eingerichtet haben.
    Der Administrator der pfSense ursprünglich aufgesetzt hat ist leider nicht mehr verfügbar, daher wäre eine komplette Neuinstallation - abgesehen von der VoIP Lösung - eine ziemliche Herausforderung ...

    Gruß

    Andre



  • Habe mir einmal per WebGUI die Sicherung der Daten vorgenommen und mit einem Tool (habe den Namen im Moment nicht zur Hand) die CF Card auch noch mal als Image gesichert. Mir ist das auch ein paar mal passiert.



  • Du kannst dir die config.xml sichern und ändern

    !!!VORSICHTIG ARBEITEN!!!

    Step-by-Step

    1. per Shell / Monitor + Tastatur einloggen
    2. cd /conf
    3. ls müsste eine config.xml ausspucken
    4. cp config.xml config.backup.19.03.2013.xml
    5. ls spuckt jetzt 2 Dateien aus config.xml und config.backup.19.03.2013.xml
    6. ee config.xml (Dateieditor)
    7. suchen nach "192.168.13.0"
    8. die "versaute" Regel suchen, löschen, speichen und neu starten

    !!!VORSICHTIG ARBEITEN!!!


Log in to reply