Wlan with blackberry playbook



  • hi,
    i have now bought an usb wireless adapter to be able to make an access point out of my alix 2d13 board (http://forum.pfsense.org/index.php?topic=58725.new;topicseen#new). the wlan usb adapter is a "techniclan wusb-150gn" and it has, according to amazon, the Ralink RT3070 chipset. it is perfectly running under pfsense till now but i have some problems with the client which is blackberry playbook:

    the playbook is able to connect to the wlan interface, but it reconnects after 1-2 mins. i tried out wpa and wpa2 with DHCP and static ip but the same behavior. it was quite worse when i configured wpa2. my configuration of the wlan interface is attached.

    can anyone tell me if there is some option to make the connection persist or to be better like it is now? I connected the playbook prior with a AVM Fritz!Box 7170 and i havent had such problems.

    update 12 of march 2013:
    now the wlan adapter disappeared completely from pfsense web interface. must have been too many connection resets. :) it is still shown in the shell via usbconfig but it is not in the web interface any more. a reboot of the alix board doesnt help anything.



  • @coyote:

    now the wlan adapter disappeared completely from pfsense web interface.

    I don't see how that could have happened "spontaneously" UNLESS the adapter got itself it in such a state that it wasn't detected at startup but I expect that should have forced an "Assign Interfaces" dialogue on the console. Please post the output of pfSense shell command```
    /etc/rc.banner ; ifconfig

    
    @coyote:
    
    > the playbook is able to connect to the wlan interface, but it reconnects after 1-2 mins.
    
    Is there any kind of log on the playbook that contains a hint of its issue?
    
    Have you looked through pfSense logs for a hint?


  • In the meantime the wlan interface is available via the web interface again, but I dont know how.

    /etc/rc.banner ; ifconfig
    *** Welcome to pfSense 2.0.2-RELEASE-nanobsd (i386) on xxx ***

    WAN (wan)                -> vr1        -> xxx
      LAN (lan)                -> vr0        -> xxx
      DMZ (opt1)                -> vr2        -> xxx
      WLAN (opt2)              -> run0_wlan1 -> NONE

    run0: flags=8b02 <broadcast,promisc,allmulti,simplex,multicast>metric 0 mtu 2290
            ether 00:aa:bb:00:11:22
            media: IEEE 802.11 Wireless Ethernet autoselect (autoselect <hostap>)
            status: no carrier
    run0_wlan1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            ether 00:aa:bb:00:11:22
            inet6 fe80::2aa:bbff:fe00:11:22%run0_wlan1 prefixlen 64 scopeid 0xa
            nd6 options=43 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: no carrier
            ssid TEST channel 11 (2462 MHz 11g)
            country US authmode AUTO privacy OFF deftxkey 3 TKIP 2:128-bit
            TKIP 3:128-bit txpower 0 scanvalid 60 protmode OFF dtimperiod 1 -dfs

    I am trying to get the log...</hostap></performnud,accept_rtadv></broadcast,simplex,multicast></hostap></broadcast,promisc,allmulti,simplex,multicast>



  • I suggest you try a recent snapshot build of pfSense 2.1 because it will include much more up to date device drivers than are in pfSense 2.0.2.

    Your run interfaces are reported "no carrier" even though in hostapd mode. Because the interface is not "UP" (in ifconfig) I suspect it is not enabled in pfSense.



  • A recent snapshot?it is not a test system regardless that I named the wlan's ssid TEST. If this dev release is stable enough, i will try it.

    I tested a laptop's wlan card with this wlan interface and the connection was perfect. So I opened an incident at blackberry's support to investigate if there is a problem on their side.



  • I have recently upgraded to pfSense 2.1-BETA1. it's the same behavior like on pfsense 2.0.2. I think there are two different issues, one with pfsense and one with playbook.

    1. playbook:
    the connection resets every 1-2 minutes when it is on WPA/WPA2 mode. this must be an blackberry issue.

    2. pfsense:
    the wlan interface disappeares. i tested this with my laptop's internal wlan card to download an ubuntu image and it was fine - encrypted and without encryption - but a few minutes after the download was ready and I disconnected myself the internal wlan card. trying to connect again after some minutes it was not possible.

    pfsense before and during connection:

    usbconfig
    ugen0.1: <ohci root="" hub="" amd="">at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE
    ugen1.1: <ehci root="" hub="" amd="">at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
    ugen1.2: <802.11 n WLAN Ralink> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

    /etc/rc.banner ; ifconfig
    *** Welcome to pfSense 2.1-BETA1-nanobsd (i386) on xxx ***

    WAN (wan)       -> vr1        -> v4: xxxx/24
    LAN (lan)       -> vr0        -> v4: xxxx/24
    DMZ (opt1)      -> vr2        -> v4: xxxx/24
    WLAN (opt2)     -> run0_wlan1 -> v4: xxxx/24 vr0:

    flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>…
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>...
    vr2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>...
    enc0: flags=41 <up,running>metric 0 mtu 1536
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    pfsync0: flags=0<> metric 0 mtu 1460
           syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>...
    ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
           options=80000 <linkstate>...
    run0: flags=8a43 <up,broadcast,running,allmulti,simplex,multicast>metric 0 mtu 2290
           ether 00:aa:bb:00:11:22
           media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    run0_wlan1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           ether 00:aa:bb:00:11:22
           inet6 fe80::2aa:bbff:fe00:1122%run0_wlan1 prefixlen 64 scopeid 0xa
           inet xxxx netmask 0xffffff00 broadcast xxx.255
           nd6 options=1 <performnud>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
           ssid TEST channel 7 (2442 MHz 11g) bssid 00:aa:bb:00:11:22
           country US authmode WPA2/802.11i privacy MIXED deftxkey 3
           AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 0 scanvalid 60
           protmode OFF dtimperiod 1 -dfs</hostap></performnud></up,broadcast,running,simplex,multicast></hostap></up,broadcast,running,allmulti,simplex,multicast></linkstate></up,pointopoint,running,multicast></rxcsum,txcsum></up,loopback,running,multicast></promisc></up,running></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></ehci></ohci>

    I assume then, pfsense reboots on its own because it is not possible to log in on to the web interface for short. pfsense looks later like this:

    usbconfig
    ugen0.1: <ohci root="" hub="" amd="">at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE
    ugen1.1: <ehci root="" hub="" amd="">at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
    ugen1.2: <802.11 n WLAN Ralink> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

    /etc/rc.banner ; ifconfig
    *** Welcome to pfSense 2.1-BETA1-nanobsd (i386) on xxx ***

    WAN (wan)       -> vr1        -> v4: xxxx/24
    LAN (lan)       -> vr0        -> v4: xxxx/24
    DMZ (opt1)      -> vr2        -> v4: xxxx/24
    WLAN (opt2)     -> run0_wlan1 -> vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric


    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>...
    vr2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>....
    enc0: flags=41 <up,running>metric 0 mtu 1536
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    pfsync0: flags=0<> metric 0 mtu 1460
           syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
           options=3 <rxcsum,txcsum>....
    ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
           options=80000 <linkstate>...</linkstate></up,pointopoint,running,multicast></rxcsum,txcsum></up,loopback,running,multicast></promisc></up,running></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast></ehci></ohci>

    I can not recognize anything in the logs.

    finally, is it worth further trouble to investigate, or not? it would be helpful if someone gives me an advise which - usb device -I can use.




  • One thing that hasn't been mentioned so far in this topic is that the run devices need to have firmware loaded. If the device is recognised on startup the driver can't load the firmware because the file system isn't mounted at that time. Adding the line```
    runfw_load="YES"



  • ehm, sorry, but how do I make the filesystem writable?



  • See http://doc.pfsense.org/index.php/Remount_embedded_filesystem_as_read-write

    I don't have experience with the nanoBSD version but I expect you could use Diagnostics -> Edit File



  • *** yeah! ***
    the issue with pfsense is fixed!
    configuring a /boot/loader.conf.local with that value and that was it. the wlan interface doesnt disappear any more. I had at the beginning two to three strange reboots of pfsense, but now it is running fine for about three hours.

    the playbook still has the continuous wlan connection resets, but this is rather a blackberry problem. I will call the support these days



  • oh man,
    the blackberry support isn't very knowledgable. They say, there is only one solution: 2,4 Ghz: 802.11 g/b
    ouaahh! That was the only information I didnt mention.  ::) I am sure, that's an answer of the 1st line support.
    Anyway…I will contact them again...

    Now, in the wireless logfiles it is displayed that the playbook loses the connection and instantly reconnects, but I can't see the reason why. Additonally, I have put the logfile from playbook (debug mode), but there I can't see the reason, too.

    playbook:

    
    --------- beginning of /dev/log/system
    03-23 00:31:52.427 W/InputManagerService(68710433): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@7a1ff980
    03-23 00:31:52.440 D/Binder  (67772443): Generated cookie e9e80055 for dup message of fd 139, to pid 68710433 chid 1
    03-23 00:31:54.283 I/QNXNavigatorClient(68710433): onActive: cid=30350483597 false
    03-23 00:31:54.342 I/QNXNavigatorClient(68710433): onWindowState: cid=30350483597 state=thumbnail
    03-23 00:31:54.344 W/Lowmemorykiller(67739672): android_monitor_thread: window state changed to 1
    03-23 00:31:54.790 I/QNXNavigatorClient(68710433): leaveGroup: 0
    03-23 00:31:54.791 D/qnx.Launcher(68710433): launching uri android://com.qnx.android.app.launcher/?activity-name=com.qnx.android.app.launcher.LaunchActivity
    03-23 00:31:54.794 I/ActivityManager(68710433): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10000000 cmp=com.qnx.android.app.launcher/.LaunchActivity (has extras) } from pid 68710433
    03-23 00:31:54.807 D/wifi    (68710433): status: wifi-state=7
    03-23 00:31:54.821 D/WindowManager(68710433): Enabled close button: Window{7a25c818 com.qnx.android.app.launcher/com.qnx.android.app.launcher.LaunchActivity paused=false}
    03-23 00:31:54.832 D/WindowManager(68710433): Enabled close button: Window{7a25c818 com.qnx.android.app.launcher/com.qnx.android.app.launcher.LaunchActivity paused=false}
    03-23 00:31:54.845 D/Binder  (67772443): Generated cookie e9ea0056 for dup message of fd 124, to pid 68710433 chid 1
    03-23 00:31:54.883 W/IInputConnectionWrapper(68714644): showStatusIcon on inactive InputConnection
    03-23 00:33:08.057 I/wifi    (68710433): network status changed: wifiEvent = 2: connected = 0, power_on = 0, ip_ok = 0, ip_address = 0x0, gateway = 0x0, nameservers = [0x0,0x0], searchdomain = "", proxy = "", interface_name = ""
    03-23 00:33:08.060 D/wifi    (68710433): stop
    03-23 00:33:08.066 D/wifi    (68710433): waitForEvent
    03-23 00:33:08.120 D/wifi    (68710433): waitForEvent
    03-23 00:33:13.122 D/WifiStateTracker(68710433): Reset connections and stopping DHCP
    03-23 00:33:13.122 D/WifiStateTracker(68710433): Disabling interface
    03-23 00:33:13.130 W/MobileDataStateTracker(68710433): Ignoring feature request because could not acquire PhoneService
    03-23 00:33:13.131 W/MobileDataStateTracker(68710433): Could not enable APN type "default"
    03-23 00:33:14.849 I/wifi    (68710433): network status changed: wifiEvent = 1: connected = 1, power_on = 1, ip_ok = 1, ip_address = 0xc0a8325b, gateway = 0xc0a832fe, nameservers = [0xc0a832fe,0x0], searchdomain = "", proxy = "", interface_name = "ti0"
    03-23 00:33:14.849 D/wifi    (68710433): scanHotspot
    03-23 00:33:14.850 D/wifi    (68710433): connectHotspot
    03-23 00:33:14.853 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.853 D/wifi    (68710433): setScanResultHandling command: 1
    03-23 00:33:14.854 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.856 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.858 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.862 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.864 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.866 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.867 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.869 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.871 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.873 D/wifi    (68710433): waitForEvent
    03-23 00:33:14.877 D/wifi    (68710433): status: wifi-state=7
    03-23 00:33:14.879 D/wifi    (68710433): getWifiInterface command
    03-23 00:33:14.880 D/wifi    (68710433): getHttpProxy command
    03-23 00:33:14.881 W/BluetoothHeadset(68710433): Proxy not attached to service
    03-23 00:33:14.882 W/BluetoothHeadset(68710433): Proxy not attached to service
    03-23 00:33:14.883 D/wifi    (68710433): setPowerMode command
    03-23 00:33:14.884 D/WifiStateTracker(68710433): DhcpHandler: DHCP request started
    03-23 00:33:14.895 D/wifi    (68710433): setPowerMode command
    03-23 00:33:14.902 D/wifi    (68710433): status: wifi-state=7
    03-23 00:33:14.904 W/NetworkStateTracker(68710433): net.tcp.buffersize.wifi not found in system properties. Using defaults
    03-23 00:33:14.906 D/WifiWatchdogService(68710433): (android.server.ServerThread) BlackBerry WiFi Network (00:1f:ca:fe:ca:fe) does not require the watchdog
    ...
    
    

    I've read somewhere that the playbook has some problems with WPA/WPA2 certificates and therefore reconnects all the time. Can this be? But this was for OS 1.x, now we have OS 2.x.

    I've experimented a little bit with the Key Rotation and the Master Key Regeneration of pfsense and the wireless connection and they have effect on the loss of connection. But it's not predictable with different values from the initially given when the connection is lost. Sometimes the connection persists for about 5 minutes and sometimes it is not able to connect at all.




  • can I raise the log settings of the System -> Wireless log? are there other options than described at http://doc.pfsense.org/index.php/Log_Settings ?



  • Blackberry answered that they have no other solution than the "2,4 Ghz: 802.11 g/b". Great…
    I think they do not want to investigate regarding a system like I have now: alix board, pfsense and the techniclan usb stick.
    I think I send the usb stick back...  :(



  • wait hold on a sec. I had problems with my playbook and another router. I was able to accomplish stability by tweaking ACK Timing settings. I remember mine disconnecting as you describe. I had to change the settings to 0 in that box. If PFsense has something similar give it a try. I also manually added the channel in the playbook and that worked.



  • thanks for the suggestion, but what is this ACK Timing settings? In pfsense there isn't something like that or it has another name(?). I've set the wlan channel to a fixed one on pfsense but the behavior of playbook didn't change.

    The only thing that has an effect on frequency of reconnecting is the Key Rotation and the Master Key Regeneration (yes, it still reconnects) but it cant be set to 0. I've set both to 9999 for testing and the connection is more stable but - I guess - to slow for e.g live streaming and sometimes even for normal "googleing". The browser can't load then the appropriate ste.

    I don't know what else to do.



  • @coyote:

    thanks for the suggestion, but what is this ACK Timing settings? In pfsense there isn't something like that or it has another name(?). I've set the wlan channel to a fixed one on pfsense but the behavior of playbook didn't change.

    The only thing that has an effect on frequency of reconnecting is the Key Rotation and the Master Key Regeneration (yes, it still reconnects) but it cant be set to 0. I've set both to 9999 for testing and the connection is more stable but - I guess - to slow for e.g live streaming and sometimes even for normal "googleing". The browser can't load then the appropriate ste.

    I don't know what else to do.

    did you do a manual connect through the blackberry? and did you try both the 2.4Ghz and 5??  did you try setting G only in the router (if there is such option).. I am intrigued cuz I was thinking about doing a box for home and I also own a playbook



    • manual connect through the blackberry? = yes
    • did you try both the 2.4Ghz and 5? = my pfsense router or rather my stick support only 2.4GHz
    • did you try setting G only in the router? = yes, you can select only between 11b and 11g

    I also set my playbook with a static IP; that should at some routers help to a persistent connection: no chance.
    Next, I want to try one or two different sticks with different chipsets. the techniclan usb stick was with rt2870 + rt3070. If that doesnt help, then I'll leave as it is, without wlan. I dont want a 3rd box for the internet.

    Which router do you have now?



  • @coyote:

    • manual connect through the blackberry? = yes
    • did you try both the 2.4Ghz and 5? = my pfsense router or rather my stick support only 2.4GHz
    • did you try setting G only in the router? = yes, you can select only between 11b and 11g

    I also set my playbook with a static IP; that should at some routers help to a persistent connection: no chance.
    Next, I want to try one or two different sticks with different chipsets. the techniclan usb stick was with rt2870 + rt3070. If that doesnt help, then I'll leave as it is, without wlan. I dont want a 3rd box for the internet.

    Which router do you have now?

    I see.. I have a Buffalo WZR-300HP2..I bought a couple of these..and they have been great..it comes with DDWRT in it..in fact I was just actually talking to an employee who affirms that opening applications that require SQL was faster under the old setup (Buffalo)..now I have everything here running on PFsense. At home my playbook didnt like the Buffalo but blackberry did an upgrade and it worked perfectly without having to tweak the settings..But going back to rt2870, I have had similar usb sticks before with Ralink and it is a hit and miss type of thing…I always have good luck with Atheros they just seem to work in my setups and actually buffalo is atheros at least on this one


Locked