OPEN VPN NO ACCEDE A EQUIPOS LAN



  • Tras seguir el manual del maestro Bellera consegui configurar open vpn en pfsense asi como el programa cliente y concecta bien. el problema es el siguiente.

    La Ip WAN de mi pfsnse es 192.168.1.249/24 (esta conectado a un enrutador ADSL)

    La ip LAN es 192.168.176.1/21 entrega dhcp para los clientes que se loguean en el portal cautivo

    Los AP que tengo conectados a la lan tienen ip 192.168.3.0/24

    La pregunta es:

    ¿Como debo configurar Tunnel network y local network para poder acceder a los ap?

    ¿Tengo que crear alguna regla que permita el paso de los ap atraves del pfsense?

    Muchas Gracias



  • http://forum.pfsense.org/index.php/topic,59116.msg318295.html#msg318295

    push route para 192.168.3.0/24 y reglas en OpenVPN que permitan el paso.



  • asi lo tengo ahora y siguo sin poder conectar, a ver si me puedes iluminar pq estoy desesperado, llevo toda la tarde haciendo pruebas y no hay manera.

    Gracias








  • Entiendo que 192.168.3.0/24 es una red que cuelga de tu LAN para fines administrativos de los APs.

    Y quieres llegar a ellos desde un Road Warrior.

    La red del túnel es exclusiva para el túnel. De hecho, si tienes un solo Road Warrior, una máscara de 29 sería suficiente. Por favor, vuelve a leer la explicación sobre asignación de IPs en OpenVPN.

    @bellera:

    http://forum.pfsense.org/index.php/topic,59116.msg318295.html#msg318295

    push route para 192.168.3.0/24 y reglas en OpenVPN que permitan el paso.



  • Gracias Bellera por el tuto lo he leido varias veces y la parte tecnica creo que la he entendido bien consiste en crear una vpn entre mi equipo (cliente) y el pfsense(servidor) para ello utilizamos un tunnel (le he dejado la ip  10.0.8.0/24.

    Una vez establecido el tunnel para ver mi subred 192.168.3.0/24 debo crear una regla que permita ver los rquipos atraves de la vpn. y aqui es donde estoy metiendo la pata y no soy capaz de dar con la solucion he probado de todo pero sigo sin ver mis equipos. segun he leido en el link que me pasaste ¿deberia ser como aparece en la imagen?

    Gracias por tu ayuda¡¡¡




  • Crea una ip virtual en la interfase LAN dentro del tramo 192.168.3.0/24.
    Esta ip virtual tiene que estar como puerta en tus APs del tramo 192.168.3.0/24.
    La regla que añadiste en OpenVPN carece de sentido, pues la default que tienes en segundo lugar permite todo.
    El problema es de ruteo de la ida y vuelta.
    Supongo que quieres un rango distinto para los APs a fin de que tus clientes no los vean.
    Es una buena medida, aunque no es segura del todo.



  • Muchas gracias.
    Sigo probando pero sin resultados positivos. La paciencia es la madre de la ciencia¡¡¡¡



  • Pues en ese caso te sugiero dejes los APs en el mismo rango (192.168.176.0/21), que sería lo más normal.

    Para que los clientes no los puedan ver puedes probar a indicarles una máscara en [DHCP Server] [Additional BOOTP/DHCP Options]

    No lo he probado nunca pero, al parecer, se puede:

    http://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xml


Log in to reply