Como Crear tunnel GRE



  • Hola amigos!

    Quisiera saber quien me prodrá guiar para crear un tunnel GRE, ya estuve varias horas en esto y no logro levantarlo (pfsense-cisco),
    Lo que estuve haciendo es lo siguiente:

    Interfaces-(assing)- pestaña GRE- +

    Parent interface= LAN (ya que el GRE destino proviene de la misma LAN)
    GRE remote address= 192.168.50.1 (¿haciendo la analogia en cisco este deberia ser "tunnel destination"?)
    GRE tunnel local address= 192.168.80.1(¿en cisco este espacio sería "tunnel source?)  
    GRE tunnel remote address= 10.0.0.1 (¿este espacio sería para colocar la ip del tunnel destino? en cisco no se pone solo la "ip address" que seria 10.0.0.2 )

    Luego en la misma opcion assing en pestaña "Interface assignments" agrego el tunnel a una interface primeramente es la OPT1, luego entro a la opcion "interfaces" y le coloco el nombre gretunnel y la ip 10.0.0.2 y MTU 1476 que corresponde con el MTU del equipo cisco. (No se si este paso de agregar una interface al GRE es correcto)

    Despues de eso creo un ruta hacia la "wan" del cisco (10.0.0.1) desde "Routing" siendo dicha IP un gateway y utilizandolo para enrutar la red que deseo ver por el GRE (192.168.200.1).

    Al hacer ping desde el PFsense logro ver:
    10.0.0.1 que es la wan del cisco
    192.168.200.1 que es la red remota del cisco no la veo hago traceroute y me lo intenta sacar por internet (osea no esta levantando el GRE) (¿como puedo ver el estado del tunnel en pfsense?¿existe algun log?

    De este paso no se que mas hacer.

    Les adjunto la configuracion del lado del router cisco

    interface Loopback0
    description *** LAN Connection ***
    ip address 192.168.200.1 255.255.255.0
    !
    interface Tunnel0
    description *** GRE Tunnel From Jakarta To Kalimantan ***
    ip address 10.0.0.1 255.255.255.0
    tunnel source 192.168.50.1
    tunnel destination 192.168.80.1
    !
    interface Fa0
    ip address 192.168.50.1 255.255.255.0
    !
    ip route 0.0.0.0 0.0.0.0 192.168.50.2

    Espero haberme explicado bien, les agradezco una mano ya que no encuentro documentacion de esto. Estoy un poco perdido….!



  • Google gre tunnel site:forum.pfsense.org

    A ver si esto te ayuda…



  • Gracias por responder,

    antes y despues de escribir el post me he mantenido googleando pero solamente encuentro foros de GRE con IPsec,
    no hablan en si de solamente GRE, de igual manera pude levantar el tunnel pero los tiempos son muy altos, luego quite el equipo cisco y coloque uno Mikrotik para probar y con este ultimo funciona perfecto…

    Ahora me pregunto cual es el maximo de tuneles puede soportar pfsesne?
    Tambien estoy poniendo a funcionar el squid sobre la interface GRE, es posible poner a apuntar el squid por varios tuneles GRE aunque sean mas de 100? (esto para sacar los sitios remotos por el squid)



  • Google bsd gre tunnel performance

    http://www.freebsd.org/cgi/man.cgi?query=gre

    http://freebsdhowto.com/FreeBSD-WIN2K-VPN-HOWTO-New-4.html

    Como que esto son pseudointerfases de red y los túneles no son encriptados no parece que tenga que haber mucha carga.

    No he encontrado datos al respecto.


Log in to reply