Pfsense su alix 2D3 HDD



  • Buongiorno a tutti.
    Dopo varie peripezie sono riuscito ad installare PFSense su un HDD collegato alla porta IDE di Alix 2d3.
    L'immagine che ho installato è la versione per CF da 4Giga.
    Le domande che vi faccio sono:
    Anche su HDD devo installare la versione per CF o posso installare un'altra versione ?
    Avendo montato una versione per CF il sistema su HDD è readonly ?
    Se fosse readonly come lo porto read/write ?

    Grazie per l'attenzione, Alberto



  • Io ho installato la versione full (quella non per CF) sull'HD IDE dell'Alix seguendo questa procedura:

    • ho preso un HD e l'ho messo in un portatile.
    • con il cdrom di PFSENSE ho installato la versione per HD.
    • poi ho smontato fisicamente l'HD e l'ho inserito nell'Alix.

    Ha funzionato.

    Bye



  • Ha scaricato livecd ?

    Grazie, Alberto



  • Sì, ho usato il live CD da un portatile. Dopo che l'ha caricato, l'ho installato sull'HD che poi ho smontato e rimontato sull'Alix. Ovviamente va scelta la versione a 32 bit. Durante l'installazione, se non ricordo male (l'ho fatta un po' di tempo fa), è possibile scegliere l'opzione senza VGA, che risulta opportuna per poter vedere la schermata della fase di boot da seriale (hyperterminal per intenderci). Ricordo che feci più prove di installazione….ad ogni modo anche se lo installi da portatile, quando lo farai partire dall'Alix, riconoscerà tranquillamente tutto l'hardware di quest'ulima.

    Francesco



  • Grazie Francesco per le info ma io non riesco a farlo funzionare.
    L'ho installato da livecd 32 come sistema embedded ma quando lo porto su alix:

    mi da errori:
    …......
    WARNING: / was not properly dismounted
    ad0: WARNING - READ_DMA UDMA ICRC error (retrying request) LBA=28618159
    ad0: WARNING - READ_DMA UDMA ICRC error (retrying request) LBA=28618159
    ad0: FAILURE - READ_DMA status=51 <ready,dsc,error>error=84 <icrc,aborted>LBA=28618159

    Io freebsd non lo conosco proprio.
    Mi sembra di capire che dovrei mettere UDMA = 0 ma non so come fare

    Alberto

    Questo è il testo completo del terminale:

    BIOS drive C: is disk0
    BIOS 640kB/261120kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (root@snapshots-8_1-i386.builders.pfsense.org, Fri Dec  7 16:39:52 EST 2012)
    Loading /boot/defaults/loader.conf
    /boot/kernel/kernel text=0x8b1454 data=0x3caa94+0x9b720 syms=[0x4+0x951e0+0x4+0xcc8e7]

    ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿
    ³                                        ³
    ³                                        ³
    ³                                        ³
    ³          Welcome to pfSense!            ³
    ³                                        ³                ______
    ³                                        ³                /     
    ³  1. Boot pfSense [default]              ³          /    f 
    ³  2. Boot pfSense with ACPI enabled      ³        /    \        /
    ³  3. Boot pfSense using USB device      ³        /  p  _
    /  Sense
    ³  4. Boot pfSense in Safe Mode          ³        \      /     
    ³  5. Boot pfSense in single user mode    ³        _____/       
    ³  6. Boot pfSense with verbose logging  ³              \        /
    ³  7. Escape to loader prompt            ³                ______/
    ³  8. Reboot                              ³
    ³                                        ³
    ³                                        ³
    ³                                        ³
    ³  Select option, [Enter] for default    ³
    ³  or [Space] to pause timer  0          ³
    ÀÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÙ

    Copyright © 1992-2010 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the 4University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 8.1-RELEASE-p13 #0: Fri Dec  7 16:48:22 EST 2012
        root@snapshots-8_1-i386.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_wrap.8.i386 i386
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Geode(TM) Integrated Processor by AMD PCS (498.05-MHz 586-class CPU)
      Origin = "AuthenticAMD"  Id = 0x5a2  Family = 5  Model = a  Stepping = 2
      Features=0x88a93d <fpu,de,pse,tsc,msr,cx8,sep,pge,cmov,clflush,mmx>AMD Features=0xc0400000 <mmx+,3dnow!+,3dnow!>real memory  = 268435456 (256 MB)
    avail memory = 243429376 (232 MB)
    pnpbios: Bad PnP BIOS data checksum
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xc0712570, 0) error 1
    wlan: mac acl policy registered
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc0712610, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc07126b0, 0) error 1
    wpi: You need to read the LICENSE file in /usr/share/doc/legal/intel_wpi/.
    wpi: If you agree with the license, set legal.intel_wpi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (wpi_fw, 0xc0891b90, 0) error 1
    K6-family MTRR support enabled (2 registers)
    ACPI Error: A valid RSDP was not found (20100331/tbxfroot-309)
    ACPI: Table initialisation failed: AE_NOT_FOUND
    ACPI: Try disabling either ACPI or apic support.
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    pcib0: <host to="" pci="" bridge="">pcibus 0 on motherboard
    pci0: <pci bus="">on pcib0
    Geode LX: PC Engines ALIX.2 v0.99h tinyBIOS V1.4a (C)1997-2007
    pci0: <encrypt decrypt,="" entertainment="" crypto="">at device 1.2 (no driver attached)
    vr0: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1000-0x10ff mem 0xe0000000-0xe00000ff irq 10 at device 9.0 on pci0
    vr0: Quirks: 0x2
    vr0: Revision: 0x96
    miibus0: <mii bus="">on vr0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr0: [ITHREAD]
    vr1: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1400-0x14ff mem 0xe0040000-0xe00400ff irq 11 at device 10.0 on pci0
    vr1: Quirks: 0x2
    vr1: Revision: 0x96
    miibus1: <mii bus="">on vr1
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus1
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr1: [ITHREAD]
    vr2: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1800-0x18ff mem 0xe0080000-0xe00800ff irq 15 at device 11.0 on pci0
    vr2: Quirks: 0x2
    vr2: Revision: 0x96
    miibus2: <mii bus="">on vr2
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus2
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr2: [ITHREAD]
    ath0: <atheros 5212="">mem 0xe00c0000-0xe00cffff irq 9 at device 12.0 on pci0
    ath0: [ITHREAD]
    ath0: AR5212 mac 5.6 RF5111 phy 4.1
    isab0: <pci-isa bridge="">port 0x6000-0x6007,0x6100-0x61ff,0x6200-0x623f,0x9d00-0x9d7f,0x9c00-0x9c3f at device 15.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <amd cs5536="" udma100="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 15.2 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    ohci0: <ohci (generic)="" usb="" controller="">mem 0xefffe000-0xefffefff irq 12 at device 15.4 on pci0
    ohci0: [ITHREAD]
    usbus0: <ohci (generic)="" usb="" controller="">on ohci0
    ehci0: <amd cs5536="" (geode)="" usb="" 2.0="" controller="">mem 0xefffd000-0xefffdfff irq 12 at device 15.5 on pci0
    ehci0: [ITHREAD]
    usbus1: EHCI version 1.0
    usbus1: <amd cs5536="" (geode)="" usb="" 2.0="" controller="">on ehci0
    cpu0 on motherboard
    orm0: <isa option="" rom="">at iomem 0xe0000-0xea7ff pnpid ORM0000 on isa0
    atrtc0: <at real="" time="" clock="">at port 0x70 irq 8 on isa0
    ppc0: parallel port not found.
    uart0: <16550 or compatible> at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
    uart0: [FILTER]
    uart0: console (9600,n,8,1)
    uart1: <16550 or compatible> at port 0x2f8-0x2ff irq 3 on isa0
    uart1: [FILTER]
    RTC BIOS diagnostic error 80 <clock_battery>Timecounter "TSC" frequency 498052383 Hz quality 800
    Timecounters tick every 10.000 msec
    IPsec: Initialized Security Association Processing.
    usbus0: 12Mbps Full Speed USB v1.0
    usbus1: 480Mbps High Speed USB v2.0
    ugen0.1: <amd>at usbus0
    uhub0: <amd 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus0
    ugen1.1: <amd>at usbus1
    uhub1: <amd 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus1
    ad0: 57231MB <hts541060g9at00 mb3oa56j="">at ata0-master UDMA100
    Root mount waiting for: usbus1 usbus0
    uhub0: 4 ports with 4 removable, self powered
    Root mount waiting for: usbus1
    uhub1: 4 ports with 4 removable, self powered
    Trying to mount root from ufs:/dev/ad0s1a
    WARNING: / was not properly dismounted
    ad0: WARNING - READ_DMA UDMA ICRC error (retrying request) LBA=28618159
    ad0: WARNING - READ_DMA UDMA ICRC error (retrying request) LBA=28618159
    ad0: FAILURE - READ_DMA status=51 <ready,dsc,error>error=84 <icrc,aborted>LBA=28618159
    g_vfs_done():ad0s1a[READ(offset=14652456960, length=65536)]error = 5
    vnode_pager_getpages: I/O read error
    exec /sbin/init: error 5
    init: not found in path /sbin/init:/sbin/oinit:/sbin/init.bak:/rescue/init:/stand/sysinstall
    panic: no init
    cpuid = 0
    Uptime: 4s
    Cannot dump. Device not defined or unavailable.
    Automatic reboot in 15 seconds - press a key on the console to abort</icrc,aborted></ready,dsc,error></hts541060g9at00></amd></amd></amd></amd></clock_battery></at></isa></amd></amd></ohci></ohci></ata></ata></amd></isa></pci-isa></atheros></generic></mii></via></generic></mii></via></generic></mii></via></encrypt></pci></host></software></mmx+,3dnow!+,3dnow!></fpu,de,pse,tsc,msr,cx8,sep,pge,cmov,clflush,mmx></icrc,aborted></ready,dsc,error>



  • Il problema è anche che non riesco a fermarlo per poter fare delle modifiche continua a riboottare.
    Ho provato con esc, ctrl c ma niente continua a fare reboot



  • Strano, a me non fece tutto sto caos.
    Quando l'hai fatto partire dall'Alix, hai sfilato la CF?



  • si



  • Boh da questa cosa non ne esco.
    Probabilmente ho qualcosa nel bios che non va a partire da esso stesso.
    Di fatti non riesco ad entrarci, penso che a forza di attaccare e staccare corrente dal connettore si
    sia sporcato il bios.
    All'avvio non vedo + il test della memoria scorrere e anche se tengo premuto il pulsante s1 sul mb
    non entra nel bios ma si blocca li.
    Anche mettendo la CF con su l'aggiornamento del bios nonn riesco a ripristinarlo
    Ora ho ordinato la schedina per il ripristino del bios speriamo.

    Se nel frattempo avete info utili, io son qui :)

    Alberto


Log in to reply