Captive portal DNS (Solved)



  • I am a newbie trying to set up my first instance of pfSense with a captive portal.  My problem seems to be a common one but despite searching the forum I am still unable to fix it.

    The captive portal will only bring up the log in screen when I use ip numbers not domain names.  Clearly I have not DNS set up properly on the LAN side.  However one I log in all external sites resolve fine on the LAN. (Same if I turn off captive portal)

    I have the DNS forwarder enabled and my System dns settings have:
    1st  LAN card ip
    2nd  WAN card ip
    3rd  broadband router IP
    4th   Google nameserver

    DHCP is working fine on the LAN but I notice it gives Client machines the LAN interface as the gateway but the DNS ip as the one of my internet router/modem.

    Any suggestions as to how I might fix the problem?
    Thanks,  Jodel



  • @jodel:

    DHCP is working fine on the LAN but I notice it gives Client machines the LAN interface as the gateway but the DNS ip as the one of my internet router/modem.

    You probably need to turn off Allow DNS server list to be overridden by DHCP/PPP on WAN on the pfSense page System -> General Setup.



  • Thanks for reply.  I had that box unticked but made sure it was off and saved.  The problem remains the same.



  • Do you have DNS server specified on the LAN tab of Services -> DHCP Server?



  • I do and the dhcp server is still sending the system dns server ip for the wan to the Clients.

    My IPs are as follows.

    My broadband router/modem      192.168.1.1
    The WAN interface ion pfSense    192.168.1.90  (static)
    The LAN interface ion pfSense      192.168.2.1  (static)

    I have enabled DHCP service on the LAN and given 192.168.2.1 as the DNS server.
    I have dns forwarding on.

    When a client connects it still gets 192.168.1.1 for DNS server not 192.168.2.1.
    Where am I going wrong?
    The help is appreciated.  Jodel



  • The problem solved.  My fault.  I had set up networking on my client computer to get the IP only from dhcp and I had given it the dns ip specifically to be the ip of the broadband router/modem.
    Thanks for all the help.  The more I look at pfSense, the better it looks!
    Jodel


Log in to reply