Netzwerk Performance auf vSphere 5.1 nicht optimal



  • Guten Tag,

    ich nutze pfSense seit gestern in folgenden Szenario.

    Ich habe einen vSphere Host (2xIntel Xeon CPU, 32GB Ram, Raid 5, Gbit Anbindung ans Internet) als Entwicklungs/Experimentier-Host.

    Bisher hatte ich alle virtuellen Maschinen (WinServer 2008 R2, Debian x64, CentOS 6 x64 usw.) mit einer öffentlichen IP aus meinem Subnetz laufen. Ist natürlich suboptimal in Sachen Sicherheit und in Sachen IP-Verbrauch. Nun habe ich das ova Image von pfSense 2.1 importiert, VMWare Tools installiert und 2 zwei vmxnet3 Adapter konfiguriert. FUnktioniert so weit. Bin per oVPN im LAN usw. alles super.

    ABER… Einige Maschinen müssen regelmässig sehr große Datenmengen runter bzw. hoch laden. Die VMs sind jetzt alle mit einer internen IP konfiguriert und benutzen pfSense als Gateway. Leider ist die Download/Upload Leistung ins Internet über pfSense eingebrochen. Vorher konnte ich teilweise mit 60MB/s operieren, jetzt sind es meistens ~20MB/s und vor allem schwankt die Geschwindigkeit stark. Also in der einen Sekunde sind es 23MB/s, dann wieder 6MB/s.

    Wo könnte ich nachtunen? Klar, ich hab nen weiteren hop. Aber Gbit sollte es ja schultern.

    Die pfSense VM wurde mit dem pfSense 2.1 ova Image erstellt. 1vCPU 3,3Ghz+1GB Ram.

    Viele Grüße



  • Hi
    Hast du das schon gelesen: http://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards hat bei mir was gebracht! Jedoch habe ich eine echte Harware Maschine.

    Unter System -> Advanced -> System Tunables findest du weitere nützliche Einstellungen…


Log in to reply