Problem with LightSquid Realtime Proxy Stats



  • I have been trying for hours, re-installing SQstat and trying new settings … I just can not get real-time monitor to work.
    I searched the forums and Googled but but I can not seem to find any other reason why it will not work. Squid is working and I can view the Lightsquid report details... The only thing I have found is that by reviewing the page data in chrome I see there is some sort of access errors - See Screen Shot

    I'm not sure what the php access error means ... Anyone have any ideas ?
    Im running 2.0.2 release AMD64

    Thanks in advance!




  • Check your Squid configuration - you may need to change the Proxy Manager setting so that it includes the IP of the interface which will be used to access the Lightsquid stats and delete the loopback IP (127.0.0.1).  If this doesn't fix it set it back to what it was and get back to us!



  • @darnitol:

    Check your Squid configuration - you may need to change the Proxy Manager setting so that it includes the IP of the interface which will be used to access the Lightsquid stats and delete the loopback IP (127.0.0.1).  If this doesn't fix it set it back to what it was and get back to us!

    I removed the 127.0.0.1 and then added to squid config …

    # Allow external cache managers
    acl ext_manager src 192.168.100.1/32
    http_access allow manager ext_manager
    

    I also tried single IP of 192.168.100.1, No change.
    I also noticed that the ProxyServer-Realtime Tab does not not show anything either. Not sure if thats a tip-off to anything.

    Thanks,



  • Have you enabled logs under Squid?  Do you have it pointed to the /var/squid/log directory?



  • I had this problem with lightsquid also.  1.8.2 pkg v.2.32

    I also found another issue, but both issues are caused by the addition of the LAN IP being added to the external cache manager block in squid when lightsquid is installed.  If my lightsquid is installed and working correctly I can see both the real time monitor and the logs.  All is well.  But then if I want to add a banned domain to the blacklist, I will get an error that my cache manage IPs are not valid.  This is caused because lightsquid inserts my LAN IP on the external cache manager line and apparently squid doesn't like that.  However, If I delete the LAN IP from the external cache manager, I can then add my banned IPs, however real time monitoring in squidlight will cease to function.

    So, I have a choice.  Either the interface will allow me to have a functioning realtime monitor in squidlight or the ability to add and subtract black listed domains, but apparently no both simultaneously.



  • The fix is really simple. Click “Services” -> “Proxy Server” -> “Local Cache” and insert the IP address for your PFsense box into the box labeled “External Cache-Managers”. The loopback will not work, it needs to be the IP of the interface running squid (most likely your internal interface).



  • I've done this (the easy fix) but my SQStat is still empty.  I notice though the the screen is showing the loopback address, but I think I want/need it to show the LAN ip address:



  • Ugh…can't believe how many hours I've spent trying to get this one thing to work!  grrrrrrrrrr :-[