Intel d2500cc проблема с em0



  • пользуюсь 2.1-BETA1 (amd64) , каждый день обновляюсь. Но в обновлениях примерно начиная с 20 марта начались проблемы с em0
    kernel: em0: link state changed to DOWN
    kernel: em0: link state changed to UP
    и так по кругу! при этом загрузка процессора около 60%. Откатываюсь на любую версию до 20 марта (к примеру от 13 марта) и все работает нормально.



  • Обновляюсь не каждый день, сейчас от 23.03 стоит, все нормально



  • @mikhe:

    Обновляюсь не каждый день, сейчас от 23.03 стоит, все нормально

    У меня проблема вылезает только если вынуть и вновь вставить шнурок в em0. То есть после обновления все ок, но стоит только передернуть
    шнурок как все начинается. Помогает только откат на версии до 20 числа.



  • Сегодня еще раз решил обновиться. Опять то же самое.
    Вот логи:

    Mar 29 12:09:44	kernel: em0: link state changed to DOWN
    Mar 29 12:09:46	php: : DEVD Ethernet detached event for lan
    Mar 29 12:09:46	check_reload_status: Linkup starting em0
    Mar 29 12:09:46	kernel: em0: link state changed to UP
    Mar 29 12:09:48	php: : DEVD Ethernet attached event for lan
    Mar 29 12:09:48	php: : HOTPLUG: Configuring interface lan
    Mar 29 12:09:49	kernel: em0: link state changed to DOWN
    Mar 29 12:09:49	check_reload_status: Linkup starting em0
    Mar 29 12:09:51	php: : DEVD Ethernet detached event for lan
    Mar 29 12:09:51	check_reload_status: Linkup starting em0
    Mar 29 12:09:51	kernel: em0: link state changed to UP
    Mar 29 12:09:53	php: : DEVD Ethernet attached event for lan
    Mar 29 12:09:53	php: : HOTPLUG: Configuring interface lan
    Mar 29 12:09:53	check_reload_status: Linkup starting em0
    Mar 29 12:09:53	kernel: em0: link state changed to DOWN
    Mar 29 12:09:56	php: : DEVD Ethernet detached event for lan
    Mar 29 12:09:56	check_reload_status: Linkup starting em0
    Mar 29 12:09:56	kernel: em0: link state changed to UP
    Mar 29 12:09:58	php: : DEVD Ethernet attached event for lan
    Mar 29 12:09:58	php: : HOTPLUG: Configuring interface lan
    Mar 29 12:09:58	check_reload_status: Linkup starting em0
    Mar 29 12:09:58	kernel: em0: link state changed to DOWN
    Mar 29 12:10:01	php: : DEVD Ethernet detached event for lan
    Mar 29 12:10:01	check_reload_status: Linkup starting em0
    Mar 29 12:10:01	kernel: em0: link state changed to UP
    Mar 29 12:10:03	php: : DEVD Ethernet attached event for lan
    Mar 29 12:10:03	php: : HOTPLUG: Configuring interface lan
    Mar 29 12:10:03	check_reload_status: Linkup starting em0
    Mar 29 12:10:03	kernel: em0: link state changed to DOWN
    Mar 29 12:10:06	php: : DEVD Ethernet detached event for lan
    Mar 29 12:10:06	check_reload_status: Linkup starting em0
    Mar 29 12:10:06	kernel: em0: link state changed to UP
    Mar 29 12:10:08	php: : DEVD Ethernet attached event for lan
    Mar 29 12:10:08	php: : HOTPLUG: Configuring interface lan
    Mar 29 12:10:08	check_reload_status: Linkup starting em0
    Mar 29 12:10:08	kernel: em0: link state changed to DOWN
    Mar 29 12:10:11	php: : DEVD Ethernet detached event for lan
    

    upd:  Проблема решена! Удалил, и заново настроил интерфейс  и все пошло.



  • Была такая проблема и на релизах
    решалась подпоркой из-под рута
    crontab -e
    0-59 * * * * /sbin/ifconfig em0 up


Locked