Client Export Utility installer doesn't install in Windows 8



  • Not sure if this is a bug or an issue w/ this Windows 8 machine.

    I did find a workaround and am up and running.
    I'm posting this in case others have the same problem.

    Specs:
    Windows 8 Basic x64 - AMD E1 w/ 4GB RAM
    AV is MSAV. Only other software is basic HP OEM.
    OpenVPN Installer is from the OpenVPN Client Export Utility 1.0.4

    Symptoms:
    When I run the OpenVPN installer on this Win 8 machine, it seems to finish prematurely and doesn't install OpenVPN.
    It installs the user config stuff but not the OpenVPN software (or TAP).

    The installer from the previous ver of the Client Export Utility installed normally on this system.

    Here's the details:
    When the installer runs it unloads openvpn-postinstall.exe and openvpn-install.exe into a temp folder.
    It launches openvpn-postinstall.exe.  Right after, openvpn-install.exe (the OpenVPN installer) should also be launched.

    openvpn-postinstall.exe runs and installs certs and config info just fine but then openvpn-install.exe is never launched.

    I completely cleaned out the old install then downloaded fresh copies of the installer onto this Win8 machine and got the same result.

    None of the compatibility settings made any difference. Nor did running as an administrator (per use, per user or for all users).

    HOWEVER, I downloaded the same installer onto a different Win8 (Ent VM) and it installed normally.

    I ran Process Monitor and reviewed several install attempts but nothing looks broken.
    openvpn-install.exe simply never gets launched.  I can't guess why.

    Last thing:
    When I went into the temp folder and manually launched openvpn-install.exe, it ran and OpenVPN installed normally.

    I'm just wondering if it's a bug w/ this version of the Client Export Utility.

    Thanks for reading.



  • I did an install on Windows 8 within the last week and it worked fine, no differently than Win 7. Seeing that on multiple systems? Anyone else seeing it?


  • Rebel Alliance Developer Netgate

    How large is your exported exe file? It sounds like what happens when the actual installer exe isn't getting into the bundle.

    That's happened before but only when I was doing development on the package and never in a version that was released that I'm aware of.

    Uninstall the export package (from pfSense, not windows), then install it again, and see if it persists.



  • I have had the 2.3-x86 client package installed on a Windows8 laptop for a month OK.



  • Installed on two Windows 8 without any problem..



  • I am wondering, I've got pfSense2.0.2 running and Client Export util 1.0.5 but on the Client Export tab, I only see options for 2.2 or 2.3-x86 (no x64 bundle)
    Is there some extra setup or voodoo I need to do to allow for an x64 compatible bundle to appear here?

    screenshot:


  • Rebel Alliance Developer Netgate

    just use the 2.3-x86 no harm in using that on windows x64.

    Last time I tried the x64 installer it just didn't work. I'm not sure if it needs some other config embedding trickery or what, but it was quite broken.



  • But does the x86 installer come with the 64-bit TAP drivers? I would think 'no' – tbh I have not tried.


  • Rebel Alliance Developer Netgate

    @luckman212:

    But does the x86 installer come with the 64-bit TAP drivers? I would think 'no' – tbh I have not tried.

    The tap installer is a separate file included inside the OpenVPN installer. As far as I can see, that does have drivers for both architectures in it. At least it's never complained for me on x64 Windows 7 or Windows 8, and looking at the various strings in the driver details I see amd64 mentioned.



  • Hmm you seem to be right – I downloaded openvpn-install-2.3.1-I001-i686.exe just now, and extracted all of its contents using 7zip. The installer contains both the x86 and x64 flavors of the tap driver.  I didn't try to install it but it seems that it would work... not sure why they even roll a separate 64-bit installer then?


  • Rebel Alliance Developer Netgate

    IIRC it's for the native windows OpenVPN GUI's 64-bit version and underlying binaries, not for the drivers.


Log in to reply