2.1 got corrupted .



  • My install seemed to have gotten corrupted. all of a sudden my internet was not working and a bunch of messages about cannot define table bogonsv6. Anyhow I tried to go back to lastest version via ssh console and just hitting "auto" but the install failed with cannot write to disk "full". Not even sure why the disk got full all of a sudden. Anyhow I have a mac using minicom and attached to the null modem cable via usb adapter. I can't get a console? I tried screen /dev/tty.usbserial and all I get are question marks. In minicom I don't get much I set the baud to 9600 8n1 and still nothing. How can I get into the console to see if I can salvage my pfsense.all I get is a bunch of question marks? I have a screen hooked up to it and I'm choosing boot pfsense(default) but then I get a line of ?????????????????????????????????? and that's it



  • no one?


  • Netgate Administrator

    This might get more response in the 2.1 subforum, if it's 2.1 specific.
    What hardware are you running? Which install type?
    I would suggest possible HD failure. Without more info it's impossible to know.

    Steve


  • Rebel Alliance Developer Netgate

    If you were on an older 2.1 image on a platform with low RAM (e.g. ALIX) it may not have had enough table space to hold the IPv6 bogons list. On newer snaps it's not loaded if there isn't enough room.

    The disk could be full due to packages you have installed, but you haven't given us nearly enough information to form any kind of accurate guesses.



  • what info do you need? I'm just about to reinstall this thing. I can't even get that to work. I honestly don't remember how I got this to install. I have the sata/ide to usb adapter and I remember using the adapters to boot from an internal cdrom drive I had laying around. When I plug it into the neoware it says boot from cd: but then just goes to F1 pfsense and then hangs at the "/". someone please explain to me if I need the null modem cable or not. I burned the nano-vga… so I'm assuming I don't need to use the null modem cable? I thought embedded images now support vga? I used this link when I first did this
    http://www.hammerweb.com/blog/2011/11/installing-pfsense-2-0-on-an-embedded-platform-the-easy-way/



  • I'm starting to think that link I posted above is going about the install a different way as documented anywhere on this site?. I think for a DOM installation I need to use the live cd and then install it. I started reading the definitive guide last night which I guess I should of done first but that link made it so easy. It seems that the nano embedded images are written to CF cards and are not written or burned to cd as I'm trying to do? Am I correct here. I'm also glad that I read that I can preserve my configs using preflight installation. So what do I need to follow for installation on a neoware thin client with a 512 MB DOM and can I just hook up the monitor and use it through out the whole installation process or will I need the use the null modem cable at some point?


  • Netgate Administrator

    Ok, so you are running on some sort of thin client like in the link?

    Yes, the NanoBSD images are supposed to be written directly to the flash media. They are not ISO CD images.
    So you can either install from a CD temporarily hooked up, as in the linked blog, or write the NanoBSD image to the DOM in another machine.

    I would choose the NanoBSD option. You get other advantages on top of the embedded kernel.

    Steve

    Edit: Ah, you edited while I was typing!  ::)


  • Netgate Administrator

    If you use the Nano+VGA images you don't need to use a null modem cable, everything can be done via the keyboard/monitor.

    You will, as I said, have to put the DOM into another machine to write to it which may or may not be easy for you.

    Steve



  • so with a 44-pin IDE DOM how would I hook it up to something another machine? I would need something in that machine to hook up that 44 pin DOM to and I'm not sure that I do. what benefits do you get with the nano? I just want to get this going and honestly I'm going to look into getting some newer hardware down the road. I'll post in different forum for recommendations on hardware. I'm basically using at home . I download video from my ps3 via amazon and play ps3 games online. I'll get some recommendation for the best fit for that type of use. There must be some type of an adapter that I can just hook up to my USB on my MAC?



  • I have this, I wonder if I can hookup the 44pin DOM to it, isn't 44 pin dom JUST 2.5 INCH I CAN HOOK UP?

    http://www.amazon.com/Vantec-CB-ISATAU2-Supports-2-5-Inch-5-25-Inch/dp/B000J01I1G/ref=pd_cp_pc_0


  • Netgate Administrator

    @http://www.freebsd.org/doc/en/articles/nanobsd/:

    The features of NanoBSD include:

    Ports and packages work as in FreeBSD — Every single application can be installed and used in a NanoBSD image, the same way as in FreeBSD.

    No missing functionality — If it is possible to do something with FreeBSD, it is possible to do the same thing with NanoBSD, unless the specific feature or features were explicitly removed from the NanoBSD image when it was created.

    Everything is read-only at run-time — It is safe to pull the power-plug. There is no necessity to run fsck(8) after a non-graceful shutdown of the system.

    Easy to build and customize — Making use of just one shell script and one configuration file it is possible to build reduced and customized images satisfying any arbitrary set of requirements.

    Not mentioned there is that NanoBSD maintains two slices, running and backup. When you do a firmware upgrade it switches to the other slice so you can always fall back to the original. Mostly it is specifically designed for running from flash media with limited write cylces. Depending on what you're doing you may not have a problem with that. I know, for example, that Wallabybob has a box running a full install, standard kernel, on a DOM. 4 years no problems. YMMV!

    You can certainly get a USB-IDE adapter that will work for this. If you've been running a CD installed embedded kernel, like the linked blog, with no no problems before then keep doing that.  :) That adapter you linked to will work. You could also use an old laptop if you have one.

    Steve



  • Happened to me once, turned out to be a drive failure



  • Might be hardware issue. CD drive I has was bad so it wasn't booting , luckily I had another one laying around but now it starts to boot and I get a mount error and something about trying to run set vts.root.mount.options=rw and remove anything from /etc/fstab? I don't know I was going to try some of the suggestions here http://doc.pfsense.org/index.php/Boot_Troubleshooting
    can anyone else think of anything I can do before trashing this thin client. I'm not sure at this point if the DOM is bad or if it's something I can fix along the boot process with the Live cd


  • Netgate Administrator

    What sort of CD drive are you using? Which image did you use to write the CD?
    It could be a bad DOM but it seems unlikely. Were you previously running any packages?

    Steve



  • It's just an internal cdrom drive from an old computer I have laying around which I'm using that kit listed above (post 13) to hook up to the usb of thin client. I used the pfSense-LiveCD-2.0.2-RELEASE-i386-20121207-1630.iso. I had snort and pfblocker packages installed

    http://www.amazon.com/Vantec-CB-ISATAU2-Supports-2-5-Inch-5-25-Inch/dp/B000J01I1G/ref=pd_cp_pc_0


  • Netgate Administrator

    Ah! I didn't read that properly, I didn't realise you already had that USB-IDE adapter.  :-[
    If you're using it with the CD drive you will probably need to do this:
    http://doc.pfsense.org/index.php/Boot_Troubleshooting#Booting_from_USB

    You should be able to use that kit to write one of the Nano images directly to the DOM from another box though.

    Running Snort and pfblocker with only 512MB of RAM the box may have started swapping to the DOM which would increase the write count massively.

    Steve



  • I thought I could use that adapter as well for nano but it's two males. I need an adapter with female end. I'll try that when I get home tonight. I ended up throwing the broken cdrom in the canal in my backyard. LOL. I couldn't figure out why it wasn't booting.


  • Netgate Administrator

    Ah, because the DOM plugs directly into the IDE connector without a cable?



  • correct


  • Banned

    Just install the normal ISO and you are fine. It acts like a normal HD and are to be treated as one :)



  • Back in business! I did notice that live cd when choosing embedded still requires a null modem cable, which is fine as I have one :) I did notice that between linksys and my hardware(neoware- see previous posts) that the linksys appears to be faster. I know this is probably the wrong forum and I have mentioned that I should post in a different forum for sizing suggestions but since you kind people have been following my thread for a few days I will throw it out there. For home use, ps3 video games  online, streaming movies (amazon) (directv) what hardware do you recommend? I'm willing to spend like $150 - $250. I want raid1 on internal as well(might go above 250 budget:)). I want a whole setup with wifi card.As of now, I'm using my linksys as my wifi which perhaps is why it was a bit faster when using the linksys:). I'm open to kits and build it urself from scratch best bang for ur buck. Thanks to all in this thread for ur help.

    1. I want to use Snort and PFblocker and perhaps some other packages, which I'm including as part of this post to help with provisioning. I'm looking for low power consumption but I want to take advantage of some cool packages.

  • Netgate Administrator

    What speed is your WAN connection? I'm surprised that the Neoware box is not faster than the Linksys, though newer routers are quite fast. What is the spec of the Neoware box?

    Steve



  • I have 20Mbps down and 4 up. Neoware has 256 memory and 512 DOM. the Linksys does have gigabit NIC where neoware does not but  that would make a difference as it applies to transfers within LAN . i have a little netgear 8 port smart switch that everything gets plugged into like my NAS , the Linksys Router , my directv stuff etc..


  • Netgate Administrator

    At that budget you're probably looking at an Atom based box. perhaps this box: http://forum.pfsense.org/index.php/topic,60336.msg324694.html#msg324694
    If you can go a bit more a low end Sandy Bridge box is far more capable. You probably won't need that capability unless you upgrade your WAN. E.g. http://forum.pfsense.org/index.php/topic,56950.0.html

    I've not personally used either of those. All my installs are re-purposed Watchguard boxes.

    Steve



  • im using a asus eee pc with atom processor and works well, except the ralink wifi isnt recognised



  • I like this one if you can find still find it:

    http://www.newegg.com/Product/Product.aspx?Item=N82E16859324026

    dual gigE, fanless, Intel Atom D2700 2.13GHz 2C/4T


Log in to reply