Bypass firewall rules for traffic on the same interface not working



  • Hi All

    I updated my firewall from 1.2.3 to 2.0.2 with a fresh install.

    Other than slow reload times after saving settings in the browser everything seems fine except for 1 thing.

    I have the following:

    WAN: PPPoE through a Negear Modem
    LAN: 192.168.100.X

    Within my LAN I have a link to my Website host (in the same building) and the gateway is 192.168.100.7. I have setup this gateway and static rule on the firewall.

    In version 1.2.3 all I had to do was tick the "Bypass firewall rules for traffic on the same interface" but something strange happens on 2.0.2.

    We have an Ecommerce site that we use to process the orders. Browsing the site seems to be working EXCEPT for when I try reprint a document. When I click the document my browser (Chrome) says uploading in the bottom left. It goes to 14%, then 43% then back to 14%. What I think is happening is that my browser is sending/uploading an SQL command and the firewall is cutting it off. This is out of the states page:

    tcp 192.168.2.33:1433 <- 192.168.100.123:45852 CLOSED:SYN_SENT
    tcp 192.168.100.123:45852 -> 192.168.2.33:1433 SYN_SENT:CLOSED

    If I tick "Disable all packet filtering." then everything works properly/as it used to.

    I have tried manually adding rules but nothing seems to help. And like I said in 1.2.3 all I did was enable "Bypass firewall rules for traffic on the same interface" and everything worked. Any idea what is holding me up in 2.0.2.

    Any help would be much appreciated.

    Thanks

    Craig



  • Does not help you much, but i have two in a colo running 2.0.1 with this setting working.


Locked