Routage du trafic vers pfsense



  • Bonsoir
    je pose sur ce forum mon problème en espérant que je trouve la solution

    J'ai un serveur win2008 R2 sur lequel j'active le DHCP sur plusieurs étendues. J'utilises un routeur cisco et j'ai crée autant de vlans que d’tendues et je configure le ip helper address. le switch et bien configuré les port trunk son bien configurés et tout marche nikel chaque poste prend son IP du dhcp correspondant;

    Le problème c'est que je faire rediriger le trafic de tous ces étendues vers pfsense 2.0 qui va me servir comme passerelle vers internet et je me suis planté là dedans.
    je sais que je dois faire un nat ou routage du routeur vers le pfsense mais je trouve pas bien le manière de le faire. ou bie dois créer les meme vlans sur le pfsense?
    sachant que tous les postes des differents vlans du réseau peuvent pinger l'adresse du firewall qui est situé sur le premier vlan mais ne peuvent pas sortir vers internet;
    merci pour votre aide



  • Un schéma svp?

    Le pfSense se trouve sur un vlan à part? Ou sur le même vlan que certains postes?



  • Le pfsense se trouve sur le premier vlan (avec le serveur windows 2008 R2) avec un IP: 172.16.8.254 et sachant que peux le pinger à partir de tous les postes des différents vlans vu que je fais du routeur intervlan avec mon cisco 1801.

    Je pense à créer des IP virtuelles sur l'interface LAN du pfsense qui vont me servir comme des passerelles pour les différents vlan vers internet. comment le faire je suis bloqué;



  • Je pense à créer des IP virtuelles sur l'interface LAN du pfsense qui vont me servir comme des passerelles pour les différents vlan vers internet

    Est ce bien ainsi que l'on gère des VLAN ?
    Avez vous juste cherché dans ce forum avec le mot clé "VLAN" ?
    Franchement, est ce bien la réponse à une demande de schéma ?

    Une machine dans un réseau doit avoir forcément une passerelle pour accéder à d'autre réseau.
    C'est vrai pour un LAN ou un VLAN.
    Il y a, de toute évidence, ici une passerelle déjà en place !



  • Idéalement, on crée un VLAN "Internet" dans lequel on verse le pfSense. Sur le device couche 3 (votre Cisco 1801), on configure une route par défaut vers le pfSense. Le NAT, on le fait sur le pfSense (donc, vous devez natter tout vos réseaux) et non pas sur le device couche 3. Sur le pfSense, on ajoute les routes "qui vont bien (TM)" pour renvoyer le trafic à destination de vos VLAN's vers le device couche 3.

    Voilà.



  • Merci bcp ts pour vos réponse
    J'ai réglé la situation et tt marche nikel et je vous enverrai ma solution prochainement si vous êtes bien intéressés.
    Sachant que toutes vos remarques étaient correctes je vous remercies encore.

    Remarque : je me suis servi avec une seule interface au niveau du routeur. donc je ne vois pas comment ajouter la route vers le pfsense sur les interfaces virtuelles créés (vlans) par défaut sur ce dernier. (juste une question curieuese!!!).
    je connais la commande mais j'aimerai bien me convaincre avec votre solution.



  • @iyad:

    Merci bcp ts pour vos réponse
    J'ai réglé la situation et tt marche nikel et je vous enverrai ma solution prochainement si vous êtes bien intéressés.
    Sachant que toutes vos remarques étaient correctes je vous remercies encore.

    Remarque : je me suis servi avec une seule interface au niveau du routeur. donc je ne vois pas comment ajouter la route vers le pfsense sur les interfaces virtuelles créés (vlans) par défaut sur ce dernier. (juste une question curieuese!!!).
    je connais la commande mais j'aimerai bien me convaincre avec votre solution.

    Les routes ne se configurent pas sur les interfaces!!!

    Soit FastEthernet0, le nom de l'interface du routeur utilisée pour les VLANs; le routeur est la passerelle par défaut de tous les VLANs; on a 4 VLAN's: DATA (Tag 2), Voice (Tag 3), Management (Tag 99) et internet (Tag 254); le pfSense a l'IP 192.168.254.2.

    
    int fa0
     no shut
     no ip address
    !
    interface fa0.2
     description VLAN DATA
     encapsulation dot1Q 2 native
     ip address 192.168.2.1 255.255.255.0
    !
    interface fa0.3
     description VLAN Voice
     encapsulation dot1Q 3 native
     ip address 192.168.3.1 255.255.255.0
    !
    interface fa0.99
     description VLAN Management
     encapsulation dot1Q 99 native
     ip address 192.168.99.1 255.255.255.0
    !
    interface fa0.254
     description VLAN Management
     encapsulation dot1Q 99 native
     ip address 192.168.254.1 255.255.255.252
    !
    ip route 0.0.0.0 0.0.0.0 192.168.254.2
    
    

    Pas besoin d'autre routes: comme les réseau sont directement connectés, le routeur "connaît ces routes" directement…

    Pour info, un "sh ip route" permettra de voir l'état des routes.

    Hope this helps.



  • Je trouve tout cela très peu clair ! (Et pourtant on a demandé un schéma …)
    Quand à "je vous enverrai ma solution si vous êtes intéressé", ça en dit long sur le rôle d'un forum.

    Je n'utilise pas ou peu les vlan, donc je n'ai répondu que pour participer et apporter ma réflexion.
    Mais, en principe, un forum est fait pour exposer un problème, recevoir des réponses, des demandes de précision, et montrer la solution !
    C'est juste l'intérêt pour les autres membres de trouver des solutions pour leurs propres problèmes ...

    Un serveur DHCP peut servir plusieurs réseaux (ou VLAN), c'est clair.
    Mais il faut forcément un routage entre ces réseaux, et sans doute un "relais DHCP" sur chaque réseau.



  • @jdh:

    […]
    Mais il faut forcément un routage entre ces réseaux, et sans doute un "relais DHCP" sur chaque réseau.

    Ah oui de fait, j'ai oublié le "ip helper-address <ip_serveur_dhcp>" sur les VLANs qui nécessitent un serveur DHCP.</ip_serveur_dhcp>



  • Salut ts
    pour répondre à jdh je dirai que j'avais pas de problème j'aurai pas posé des questions. si non peut être je participerai à d'autres problèmes si bien sur j'aurai des idées.

    et pour répondre à psylo je vois que c'est une solution très pratique pour ma situation et je confirme que dans ce cas pas besoin de créer des vlan sur le pfsense et juste de mettre sa patte lan sur le segment vlan adéquat (en port access sur le switch).confirmé.

    Pour le relais dhcp oui c'est aussi confirmé  par le biais de l'IP HELPER au niveau du routeur.

    à propos du schéma je fais du retard car je suis très occupés ces jours mais surment je vous enverrai 1 avec la solution que j'ai trouvé.

    Merci encore à tous ceux qui on collaboré pour résoudre mon problème.



  • Un schéma + réponse serait la bienvenue, j'ai le même problème….  :-\


Log in to reply