An error code was received while attempting CaptivePortalVoucherSync



  • I use the "Voucher database synchronization" feature of the captive portal on a remote alix box, it syncs with the main captive portal via vpn, the error occurs everytime a captive portal users session expires.

    My setup is:

    vm (vpn server)–--vpn tunnel----alix
    192.168.1.x           172.16.1.x      192.168.2.x

    Systems log

    Apr 5 02:41:12 php: : New alert found: An error code was received while attempting CaptivePortalVoucherSync XMLRPC sync with https://192.168.1.1:443 - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Apr 5 02:41:12 php: : An error code was received while attempting CaptivePortalVoucherSync XMLRPC sync with https://192.168.1.1:443 - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Apr 5 02:41:12 php: : Captive Portal Voucher XMLRPC sync data https://192.168.1.1:443.

    Portal auth

    Apr 5 02:41:12 logportalauth[57608]: TIMEOUT: JHjFM3, c0:f8:da:a7:81:45, 10.0.2.146
    Apr 4 21:15:20 logportalauth[27353]: Voucher login good for 23055 min.: JHjFM3, c0:f8:da:a7:81:45, 10.0.2.146

    Is anyone else experiencing the same thing or could it be a simple config error on my part?





  • I've since migrated my setup to use freeradius authentication, I've switched voucher sync off on both the master and slave, yet I still get the same error when a user logs off on the alix (slave).

    I noticed also that even though I have "Enable Vouchers" unticked on the "Vouchers" tab, "Voucher database has been synchronized from https://192.168.1.1:443" shows up after hitting the same button.

    Any remedy apart from editing config.xml and restoring? any voucher db needs to be deleted too?

    Thanks



  • Ive since upgraded to 2.1 and it seems the config has migrated the error with it, in the end I had to edit my config and remove any reference to "vouchers", (even tho voucher support was disabled) restored the edited config, reboot and everything fine since then.


Log in to reply