Проблема с OpenVPN



  • Доброго времени суток всем!

    Есть настроенный сервер  OpenVPN на pfsense 2.0.1. Проблема заключается в том, что после подключения с внехи к нему не видно компы в локальной сети. Видно только локальный интерфейс, который смотрит в локалку.

    Перепробовал разные варианты с настройками и маршрутизацией на самом pfsens'е. Но пока результат тот же. ???

    Может кто подскажет, куда копать? Или может я что то не так делаю?

    Скрины настроек и таблицы маршрутов pfsense прилагаю.

    Заранее спасибо всем откликнувшимся!







  • Еще бы правила firewall увидеть. Самый стандартный совет: создать правило разрешающее весь трафик на интерфейсе ovpn и потом блокировать ненужное.



  • Сообственно правила фаера. :)








  • pfSense не является шлюзом по умолчанию для компов локальной сети? Зачем для LAN указан gateway (192.168.111.4)?



  • Да, pfsense не является шлюзом для локалки. 192,168,111,4-это шлюз локальной сети.



  • pfSense у вас и так в локальной сети, на нем этот шлюз указывать не надо. На шлюзе (192.168.111.4) нужно прописать маршрут в сеть VPN (10.0.1.0/24) через pfSense, либо прописать его ка каждом компе локальной сети, либо делать SNAT сети VPN на LAN интерфейсе pfSense.



  • @rubic:

    либо делать SNAT сети VPN на LAN интерфейсе pfSense.

    вот этот вариант интересен, но не понятно как его реализовать? нужно сделать НАТ через LAN для openVPN?





  • это не относится к теме -просто лучше обновиться до 2.0.2 - в 2.0.1 есть уязвимость.


Log in to reply