LAN clients can't ping/reach/access to VPN Clients.



  • Hi all.

    I need your help/advice on PFsense.

    I followed these steps "http://www.apollon-domain.co.uk/?p=433", to get my VPN Clients working. (ALL GOOD)

    VPN Clients can access to LAN network without any issue.

    I need help to get LAN, to access/ping my VPN Clients.

    I google up and found my closest solution from "http://forum.pfsense.org/index.php?topic=21941.0;prev_next=next":

    So to summarize, getting this to work required me to do the following:
      1. I followed the steps in the section "Including multiple machines on the client side when using a routed VPN (dev tun)" of http://openvpn.net/index.php/open-source/documentation/howto.html#scope
      2. Add a rule to the LAN interface to allow all traffic from the LAN net to the OpenVPN subnet.

    I try to follow that guide, but I guess I am doing something wrong here. My understand of pfsense is poor to average.
    Please help me out.

    Here's some information:-
    VPN Clients : - 10.1.5.0/24
    Home LAN: 128.0.1.0/16

    VPN Clients –-PING----> Home LAN/LAN Clients/computer (OKAY!)
    Home LAN/LAN Clients/computer ---Ping----> VPN Clients (NOT OKAY)  (Need fix)

    I basically want my LAN clients, to access to VPN Clients. I appreciate if anyone could help me.


  • Rebel Alliance Developer Netgate

    A couple things to check:

    1. Make sure LAN rules pass to the VPN without a gateway set - may not be relevant if you don't use multi-wan or don't have gateways set on any rules.
    2. Make sure you are contacting the VPN client on its proper IP (check Status > OpenVPN to find the client's IP when they are connected)
    3. Try a packet capture on the VPN interface to see if you see traffic from your LAN client trying to reach the OpenVPN client. If you do, then…
    4. Make sure that the VPN client has Windows firewall or other client firewalls disabled on the VPN interface, or else their PC may be dropping the traffic locally.



  • I had exactly the opposite problem. I couldn't ping lan computers. Here is what i did.
    First I installed pfsense 2.1 beta because 2.0.2 was too messed up by trial and error.
    I followed this guide. It tells it for "tap" vpn mode instead of "tun". Tap is more suitable for me. I tried tun mode too.
    http://hardforum.com/showthread.php?t=1663797
    Again I faced the same exact issue. But later I found it was a windows firewall issue. Just turning it off and on again somewhat solved the problem.
    If you want to follow the guide, dont forget to put rules for OpenVPN and bridge interfaces.
    And dont try to connect to your vpn from local network. Try from another computer because in 2.1beta they didn't put a backend handler so nothing works if you connect from local network. At least I couldn't do it. It was working in 2.0.2 though

    Cheers


Log in to reply