Critical time error in pfSense 2.0.3



  • when I upgraded to PfSense 2.0.3, a serious problem occured.
    time seems 3 hours earlier in Firewall and System Logs.
    for example, if the current time is 20:00, time seems 17:00 in all log files.
    and when I connect to the pfsense by ssh, when I ask the time, it shows
    3 hours earlier than the real time..

    For that reason, I started to use pfSense 2.0.2 (the earlier version)

    Any idea or any solution ?



  • Is your time zone correct? >System>General Setup>Time Zone



  • I have been living in Turkey.
    my time zone corrrect…Europe/Istanbul...
    in web gui time is shown correct...bu when i connect to pfsense server through ssh, time is 3 hours earlier than the real time
    for that reason time information in all logs is 3 hours earlier..

    when I was using pfSense 2.0.1 everything was correct. bu whenever I upgraded to pfSense 2.0.3 bu webGui...time in logs began to be 3 hours earlier...

    I guess that this may be a bug in pfSense 2.0.3, beacuse not only this problem occured in my pfsense..when I made search in internet,
    I saw that many people accrossed the same problem...

    What a pity, I couldn't find the solution...


  • Rebel Alliance Developer Netgate

    Have you rebooted since setting your time zone? Processes will only pick up the new time zone after they are restarted. If you set the time zone but have not rebooted since then, it would not have the correct time on every process on the firewall.



  • thanks for your reply..when I set my time zone from Europe/Istanbul to Asia/Istanbul and rebooted the machine, the problem solved…
    but only the problem is this: when pfSense boots, after the message "Starting ntp time client....." appears, it waits 2-3 minutes and "Hostname nor servname not provided, or not known" message appears twice, after that "Starting DHCP Server" message appears, and pfSense begins to work properly with no problem... Even if install pfSense 2.0.3 onto a new machine, the above error message occurs... bu this error message doesn't cause the pfSense not to work....

    Good luck. Have a nice day.. Thanks a lot
    @jimp:

    Have you rebooted since setting your time zone? Processes will only pick up the new time zone after they are restarted. If you set the time zone but have not rebooted since then, it would not have the correct time on every process on the firewall.



  • An alternative to this is to use an IP address of the NTP server instead of its hostname :)

    or

    Make sure that your NTP server hostname is resolvable by your DNS server.

    it should boot faster.