Proxy convierte mi MultiWan en UniWan



  • Estimados:

    Paso a detallarles la situacion de mi red, y cual es el punto donde requiero una colaboracion:

    Tengo 5 Adsl que me son provistos por diferentes operadores de acceso a internet.

    wan1
    wan2
    wan3
    wan4
    wan5

    La wan1 es la WAN por defecto en el pfSense.

    He creado reglas en el Firewall (lan), para que haga lo siguiente:

    Que ciertas ip's usen determinada wanX, asi cada departamento o zona no afectara a las otras.
    10.1.1.x ocupe wan1
    10.1.2.x ocupe wan2
    10.1.3.x ocupe wan3
    10.1.4.x ocupe wan4
    10.1.5.x ocupe wan5

    Y adicionalmente he definido el FailOver para que cuando alguna de las wanX no este funcionando, automaticamente tome alguna de las otras restantes.

    Hasta ahi todo correcto:

    Desde una maquina 10.1.1.x hago traceroute y salgo desde ese ISP (wan1); si desde 10.1.5.x hago traceroute salgo por wan5, y si desconecto el cable de ese ISP, entonces sale por wan1 o wan3 o alguna otra wanX (excepto la 5 que esta desconectada).

    El problema viene cuando activo el Proxy.!!!!!

    Todas las conexiones que salian por sus wanX respectivas, salen ahora por wan1.

    He probado cambiar el routing para indicar que el valor por defecto sea wan3, y todas las conexiones desde 10.1.Y.x salen por wan3….

    Es decir, el proxy esta haciendo que todas mis salidas hacia internet se hagan por un solo isp, la wanX que esta definida como por defecto en el routing, con la consiguiente saturacion de dicha troncal.

    Si deshabilito el proxy, entonces todas las salidas vuelven a ser normales.

    Y por que quiero habilitar el proxy y no dejarlo tal cual esta funcionando (sin proxy), si todos estan navegando????

    Pues que no puedo aplicar filtros a los sitios prohibidos, ya sean pornos, videos o redes sociales.

    Lamentablemente algunos equipos en cada una de las 10.1.Y.x deben tener ciertas restricciones y quiero generarles sus filtros respectivos, pero no puedo si todas las conexiones de todos equipos me saturan una sola salida wanX.

    Ya he seguido varios post desde este foro, y algunas ideas tomadas desde Google, pero ninguna me soluciona el problema.

    Esta es mi configuracion base y packages.

    pfSense:    2.0.1-RELEASE (i386) built on Mon Dec 12 17:53:52 EST 2011
    Packages:  squid & lightSquid

    Alguien que pueda darme una idea de porque pueda estar fallando, o alguna pauta para que pueda saber donde pueda estar el problema.

    Saludos,

    .Dark.Tech.



  • la regla de multiwan se aplica en floating usando proxy

    Saludos




Log in to reply