PFsense não reconhece a placa de rede



  • Boa noite
    Baixei a nova versão 2.0.3 , e tenho um firewall com 5 placas de rede porem ele só detecta ( sobe ) 3 delas , as duas onboard não aparecem. Dei o comando pciconf -l -v  ( abaixo ) ,, e me parece que detectou ,, porem não consigo adicioná-las, alguém sabe me dizer oque devo fazer nesse caso , Obrigado

    re0@pci0:2:0:0: class=0x020000 card=0x816810ec chip=0x816810ec rev=0x06 hdr=0x00
       class      = network
       subclass   = ethernet
    re1@pci0:3:0:0: class=0x020000 card=0x816810ec chip=0x816810ec rev=0x06 hdr=0x00
       class      = network
       subclass   = ethernet  
    re2@pci0:5:4:0: class=0x020000 card=0x816910ec chip=0x816910ec rev=0x10 hdr=0x00
       class      = network
       subclass   = ethernet
    re3@pci0:5:6:0: class=0x020000 card=0x816910ec chip=0x816910ec rev=0x10 hdr=0x00
       class      = network
       subclass   = ethernet
    re4@pci0:5:7:0: class=0x020000 card=0x816910ec chip=0x816910ec rev=0x10 hdr=0x00
       class      = network
       subclass   = ethernet



  • boa noite

    resolvido ,, verifiquei outros posts aqui mesmo no Forum . Carreguei o modulo correto no boot
    da RTL8111 , e deu tudo certo .Obrigado



  • Nada como uma boa pesquisa.  :)



  • Outro problema,,
    um outro appliance meu tem 4 placas de rede onboard rtl8111
    porem não possui mas nenhuma , e o pfsense não continua a instalação pois nao detecta
    oque posso fazer nesse caso , pois , não tenho como colocar uma placa de rede extra para poder carregar os modulos da RTL8111



  • Já tentou a versão 2.1?

    Acredito que fora esta alternativa, só te restar fazer o procedimento de criação da iso, incluindo seu driver.



  • Me desculpe a ignorância ,, mas a versão 2.1 é mais nova que essa 2.0.3 ?? é que não encontro essa 2.1 para fazer o download.

    Pois é.. eu pensei nisso
    qual o programa que voce me recomenda para abrir a ISO, colocar os arquivos la e refazer a ISO?
    seria só isso mesmo ? e mudar o loader.conf ? Obrigado



  • @evandroelmi:

    Me desculpe a ignorância ,, mas a versão 2.1 é mais nova que essa 2.0.3 ?? é que não encontro essa 2.1 para fazer o download.

    Versão mais nova? Oras, 2.1. Parece evidente, não é? ;)
    Segue o link para download da versão 2.1 Beta1:
    http://snapshots.pfsense.org/

    Trata-se de versão Beta, portanto não é muito recomendada para ambientes de Produção.



  • é imaginei rss.
    mas como não tinha na lista de downloads fiquei na duvida.
    bom…. mas obrigado , porque preciso colocar em produção , não posso usar essa



  • @evandroelmi:

    bom…. mas obrigado , porque preciso colocar em produção , não posso usar essa

    Dependendo da sua capacidade de gerar um iso, a instalação pode ficar menos estável que a versão beta da 2.1

    Se o driver não foi bem testado na 2.0.x, só o fato de usa-lo, sua instalação já tem um status beta  :)



  • Você tem ideia de quando sairá a versão estável da 2.1 ?



  • @evandroelmi:

    Você tem ideia de quando sairá a versão estável da 2.1 ?

    Nops.



  • Olá!

    Só um adendo: Placas de rede Gigabit da Realtek estão instaveis neste momento, tanto na versão 2.0.1 do PFSense que utiliza o FreeBSD 8.1, tanto na 2.1 que utiliza o FreeBSD 8.3. Acredito que só com o FreeBSD 9.x na versão 2.2 é que veremos estes Realtek estaveis.

    Isso é negativo porque boa parte das Appliances que não são Alinx utilizam este Chipsets de rede.



  • isso é péssimo ,, mas instaveis de que forma ?? perdem pacotes ,, ou oque
    voce ja fez testes com elas?
    Obrigado



  • @evandroelmi:

    isso é péssimo ,, mas instaveis de que forma ?? perdem pacotes ,, ou oque
    voce ja fez testes com elas?
    Obrigado

    O Marcelloc e acredito que o Johnnybe relataram problemas com as Realtek e Marwell Gigabit.

    Eu tive problemas com instabilidade no driver, causando travamentos no sistema e interrupções, perca de pacotes… etc.



  • instalei a 2.1 e detectou tudo …
    vou colocar esse de vou pendurar uns 20 usuarios nele com squid e squidguard ,, e ver oq acontece ,,,
    alguem sabe oq esta pendente pra essa versão virar Estavel ?



  • @evandroelmi:

    instalei a 2.1 e detectou tudo …
    vou colocar esse de vou pendurar uns 20 usuarios nele com squid e squidguard ,, e ver oq acontece ,,,
    alguem sabe oq esta pendente pra essa versão virar Estavel ?

    É um bom começo, com as placas de rede funcionando.
    Eu tenho usado a versão 2.1 no meu escritório com modem Motorola SBV5120 da Virtua em bridge, Squid e IPSEC estabelecendo VPN com algumas empresas que são meus clientes. Evidentemente, nesses clientes, ainda mantenho a versão 2.0.1 Release porque não vou arriscar Beta ou 2.0.3 a não ser que eles me peçam com todas as forças e meus argumentos não funcionem. Principalmente porque, em dois deles a conexão é PPPOE e já ouvi relatos sobre alguns problemas com a versão 2.0.3. Mas cada ambiente tem suas peculiaridades, não é?

    Focando no meu pfSense 2.1 de Mar 12 20:58:29 EDT 2013, apesar do ultimo snapshot instalado ainda estar defasado, funciona estável para o ambiente de meu escritório e meus acessos à VPN dos clientes são estáveis. Na minha rede do escritório, tenho 03 hosts Windows 7, 01 host Linux Ubuntu e 01 host Mac Leopard. Ainda não atualizei o Snapshot da versão 2.1 porque estou esperando notícias sobre estabilidade do Snort e também porque há dias atrás houve relatos sobre problemas com IPSEC em alguns snapshots mais recentes.
    Essa é a maior dificuldade com a versão 2.1, para certos ambientes: Sempre ficar atento aos problemas que porventura aconteçam com as atualizações (snapshots) mais recentes.



  • Olá!

    Só lembrando que como a versão do FreeBSD é a 8.3, realmente já melhor compatibilidade com Drivers.

    Eu pessoalmente, mesmo com a versão 2.1, experimentei instabilidade em Chipsets Gigabit da Realtek, operando em Gigabit. Se você estiver operando a placa em modo Fast(100MB/s) não haverá problema.



  • @LFCavalcanti:

    O Marcelloc e acredito que o Johnnybe relataram problemas com as Realtek e Marwell Gigabit.

    Da minha parte, inutilizável. Perde pacote o tempo todo. Em 100mbit fica tranquilo.



  • bom…

    minhas redes são todas 100mb nada de gigalan ,,, então eu acho que vou arriscar e fazer um piloto, até que eu faça uma mudança radical em minhas redes ,, "oque nao será antes de 2 anos eu creio "
    acho que até la ja teremos algo que seja estavel.


  • Administrator

    @evandroelmi:

    instalei a 2.1 e detectou tudo …
    vou colocar esse de vou pendurar uns 20 usuarios nele com squid e squidguard ,, e ver oq acontece ,,,
    alguem sabe oq esta pendente pra essa versão virar Estavel ?

    Nessa URL você pode acompanhar todos os bugs que ainda estão abertos para a versão 2.1.

    https://redmine.pfsense.org/projects/pfsense/issues?query_id=24



  • Boa tarde a todos os membros do fórum pfsense.

    Como vocês estão? Espero que estejam bem.

    Caríssimos, adquiri para um cliente a placa de rede TP-Link modelo TG-3468 de barramento PCI Express x1. Ela trabalha tanto a 10Mb/s, 100Mb/s e 1Gb/s.

    Descobri que seu chipset é da Realtek (RTL 8168B).

    Então parei o servidor pfSense 2.0.3 para instalá-la fisicamente e, para a minha surpresa, esta placa de rede não foi reconhecida pelo pfSense (mas foi reconhecida pelo Xen Server, a máquina real que provê a virtualização para o pfSense 2.0.3).

    Encontrei algumas mensagens aqui no fórum pfSense sobre este chipset não ser reconhecido pelo pfSense 2.0.3. Assim, executei os seguintes procedimentos:

    1. Acessei o prompt do servidor pfSense 2.0.3 via SSH de uma estação de trabalho;

    2. Estando logado no pfSense 2.0.3, efetuei o download do arquivo if_re.ko com o comando:
    fetch https://github.com/downloads/kelsen/modulos/if_re.ko

    3. Copiei o arquivo if_re.ko para o diretório /bot/modules com o comando:
    cp if_re.ko /boot/modules/

    4. Então carreguei/subi o módulo com o comando:
    kldload if_re.ko

    Mas quando digitei o comando:
    pciconf -l -v

    Me retornou o seguinte resultado:

    (…)

    re0@pci0:0:4:0: class=0x020000 card=0x00015853 chip=0x813910ec rev=0x20 hdr=0x00
       class      = network
       subclass   = ethernet

    re1@pci0:0:5:0: class=0x020000 card=0x00015853 chip=0x813910ec rev=0x20 hdr=0x00
       class      = network
       subclass   = ethernet

    re2@pci0:0:6:0: class=0x020000 card=0x00015853 chip=0x813910ec rev=0x20 hdr=0x00
       class      = network
       subclass   = ethernet

    Ou seja, a suposta placa de rede re3 não foi reconhecida. A re0, re1 e re2 são as placas de rede que estão funcionando antes da aquisição da placa de rede TP-Link modelo TG-3468.

    Qual o próximo passo que eu poderia fazer para reconhece-la no pfSense 2.0.3?

    No mais, muito obrigado. Desejo-lhes uma excelente quarta-feira repleta de
    paz, saúde, força e honra.

    Atenciosamente,


    Eder S. G.



  • Bom dia a todos os membros do fórum pfsense.

    Como vocês estão? Espero que estejam bem.

    Caríssimos, consegui resolver o problema do pfSense versão 2.0.3 não reconhecer a placa de rede TP-Link modelo TG-3468 de barramento PCI Express x1 como mostra a imagem acima.

    O que eu fiz foi muito simples: o cliente utiliza o pfSense 2.0.3 instalado em uma máquina virtual provida pelo Xen Server 6.2.

    Então acessei o ambiente de gerenciamento do Xen Server com o software cliente Xen Center.

    Logo após, acessei a máquina virtual pfSense. No prompt de comando, digitei a opção 6 para desligá-la.

    Depois, no Xen Center, cliquei no botão de procurar uma nova placa de rede instalada no servidor. Então tive a grata surpresa da placa de rede pci express x1 ser reconhecida no Xen Center.

    Após isso, iniciei a máquina virtual pfSense 2.0.3 e lá estava a interface de rede OPT2.

    No mais, continuemos estudando o sistema operacional pfSense e nos ajudando mutuamente.

    Desejo-lhes uma excelente quinta-feira repleta de paz, saúde, força e honra.

    Atenciosamente,


    Eder S. G.



  • Bom dia.
    @evandroelmi , como vc conseguiu resolver este problema? tem o link da solução q vc citou?
    não consegui encontrar.



  • @marcelm1 said in PFsense não reconhece a placa de rede:

    Bom dia.
    @evandroelmi , como vc conseguiu resolver este problema? tem o link da solução q vc citou?
    não consegui encontrar.

    Este tópico tem mais de 5 anos. Com certeza o driver será outro.
    Qual versão do pfSense está usando?



  • @marcelloc said in PFsense não reconhece a placa de rede:

    @marcelm1 said in PFsense não reconhece a placa de rede:

    Bom dia.
    @evandroelmi , como vc conseguiu resolver este problema? tem o link da solução q vc citou?
    não consegui encontrar.

    Este tópico tem mais de 5 anos. Com certeza o driver será outro.
    Qual versão do pfSense está usando?

    Estou usando o pfSense 2.4.2. Ele não está subindo as nics, mostra apenas 1 up, as outras 3 e a onboard como down.



  • @marcelm1 said in PFsense não reconhece a placa de rede:

    Estou usando o pfSense 2.4.2. Ele não está subindo as nics, mostra apenas 1 up, as outras 3 e a onboard como down.

    Se está mostrando como down, aparentemente reconheceu a placa.

    Se o servidor não estiver em produção, tenta atualizar para a versão 2.4.4-rc. Ela usa o freebsd 11.2 e pode ser que nele a placa reconheça melhor.



  • @marcelloc said in PFsense não reconhece a placa de rede:

    @marcelm1 said in PFsense não reconhece a placa de rede:

    Estou usando o pfSense 2.4.2. Ele não está subindo as nics, mostra apenas 1 up, as outras 3 e a onboard como down.

    Se está mostrando como down, aparentemente reconheceu a placa.

    Se o servidor não estiver em produção, tenta atualizar para a versão 2.4.4-rc. Ela usa o freebsd 11.2 e pode ser que nele a placa reconheça melhor.

    Blz.. vou baixar aqui a versao rc e já já te dou um retorno!
    Obrigado.



  • Acredito estar tendo o mesmo problema... O firewall estava funcionando normal ontem, durante a noite fiz a atualização do e2guardian e do sargento ( que acho não ter relação com o problema).
    A Wan está down, mesmo com o cabo conectado e com link.
    No system log tenho a mensagem
    rl01: unable to stop rx/tx MAC



  • @remix, já tentou reiniciar o fw? essa mensagem parece de erro no driver.



  • @marcelloc sim, acabei trocando a placa e aparentemente resolveu. Obrigado


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy