WebGUI Can't Access



  • Hi im a newbie on pfsense and i want to try it so i install it to a VMware and followed the tutorial on installing pfsense on vmware.  after installing it gave me the ip add. to access the webgui http://192.168.1.1. but i cannot access the site
    but when i try to ping the ip a got a reply…..

    what do you guys think is the problem???

    I Hope someone can help me on this....

    Thanks!!



  • make sure that webGUI protocol set to HTTP. If it set to HTTPS you need to access like https://192.168.1.1



  • Just upgraded from an older rc3 snapshot to the "final" rc3 and after booting dashboard didnt work. So i tried removing it and rebooting the firewall and not i cant access webgui anymore either.

    Any ideas where to start looking for the problem? I had my webgui set to https and i have tried accessing it trough http and https. ssh and the firewall functions are working as usual, only problem lies within the webgui

    EDIT: re-running the update from shell revived webgui for me and now the dashboard is working fine too.



  • Hdd on my firewall gave so i had to do a fresh install and the weirdest thing is that I lost webgui again. Heres the story:

    Installed bunch of packages (snort,imspector,nmap etc.) while configurin dhcp and firewall rules and after sometime i noticed that packages that I already had installed had disappeared from webgui. So I tought maybe a little kick to the webgui would do the trick and so I restarted it from console.

    After this no answer from webgui, not even after an reboot.

    Weird bug, anyone else noticed or is there something wrong with my hardware (or maybe the combo of my packages?)



  • Just did upgrade from RC2 to RC 3… Thankfully webgui works and I can access however Dashboard does not work. All other packages, iperf, ntop, darkstat, snort, etc.  still function correctly as well.



  • reinstall the dashboard.



  • This happens to me every time I upgrade and is simple to fix

    1: goto packages and remove the dashboard
    2: goto the index page and you will see a broken dashboard (just ignore it)
    3: go back to the packages menu and install Dashboard

    I don't know why but a reinstall without visiting the index won't fix the dash I just get the old index view ???



  • Yes, I can confirm that my dashboard is gone after each update.
    But it is working after uninstalling it from the packages which makes me think that there's a broken version in the background somewhere.

    Anyway, gonna re-install pfSense once 1.2 final is out, so I don't care too much.



  • This is why is says "WARNING! Cannot be deinstalled."

    It is due to the dash replacing index.php but when you upgrade the original index.php is in the package and is therefore the dash one is replaced. You then need to remove the dash to make the package system happy to reinstall it BUT this removes all the widgets that were in the package (but not ones that you have added).

    I can't quite work out why you have to visit the index page to make it restore the dash. I guess when you uninstall it restores the index.php from somewhere and you get a broken dash back. I guess visiting it resets some values on the load. ???

    The install restores the widgets and reinstalls the dash version of index.php

    I never raised this as a bug as this will all go away once the dash becomes the default (in 1.3)


Log in to reply