Arkadaşlar bu hatayı alıp çözen varmı varsa lütfen yardımcı olabilirmi tşk ler.



  • SİSTEM PFSENSE 2.0.3 RELEASE
    ÜSTÜNDE SQUID+SQUIDGUARD+LIGHTSQUID+CAPTIVEPORTA+FREERADIUS2 ÇALIŞIYOR

    ZACK USTANIN ÖNERDİĞİ ŞEKİLDE SQUID CUSTOM OPTIONS KISMINA AŞAĞIDAKİ DEĞERLERİ GİRDİM

    WAN 192.168.3.1 TPLİK MODEM
    WAN2 192.168.1.1 TPLİK MODEM
    LAN 10.0.0.1
    LAN2 10.10.0.1

    YAPI LAN WANDAN LAN2 WAN2 DEN ÇIKACAK ŞEKİLDE FİREWALL RULES YAZILDI
    ZACK USTANIN GÖSTERDİĞİ ŞEKİLDE SQUID CUSTOM OPTIONS
    acl lan src 10.0.0.0/24;
    acl lan2 src 10.10.0.0/24;
    tcp_outgoing_address 192.168.1.1 lan;
    tcp_outgoing_address 192.168.3.1 lan2;

    SQUID TRANSPARAN MODE İŞARETLİYKEN AŞAĞIDAKİ HATAYI ALIYORUM TRANSPARAN MODU KALDIRDIĞIM ZAMAN İNTERNET ÇIKIŞLARI HERŞEY NORMAL LAN WAN DAN LAN2 DE WAN2 DEN İNTERNETE ÇIKIYOR NE YAPTIYSAM BU HATAYI AŞAMADIM YARDIMCI OLABİLECEK VARSA ÜSTADLARDAN ÇOK SEVİNİRİM.

    SAYGILARIMLA…

    ERROR
    The requested URL could not be retrieved


    While trying to retrieve the URL: http://www.google.com.tr/

    The following error was encountered:

    •Socket Failure
    The system returned:

    (49) Can't assign requested addressSquid is unable to create a TCP socket, presumably due to excessive load. Please retry your request.

    Your cache administrator is admin@localhost.


    Generated Thu, 25 Apr 2013 15:06:53 GMT by localhost (squid/2.7.STABLE9)



  • ayarlar doğru gözüküyor sadece

    tcp_outgoing_address wan_interface_ip lan;
    tcp_outgoing_address wan2_interface_ip lan2;

    olacak modemin ipsi değil

    WAN GW 192.168.3.1 sizin if addr de 192.168.3.2 ,
    WAN2 GW 192.168.1.1 sizin if addr de 192.168.1.2 ise

    custom options
    tcp_outgoing_address 192.168.3.2 lan;
    tcp_outgoing_address 192.168.1.2 lan2;

    olmalidir



  • Benim wan bacaklari dhcp den otomatik ip aliyor o zaman onlari static yapip modemlerin ip blogundan bi ip vereyim ozaman dogrumu ustad bu arada modem ip sinin birisini yanlis yazmisim duzelttim valla gunlerdir ve gecelerdir ugrasiyorum buna umarim bu sekilde calisir sabah gidince ilk is denicem.
    Tsk.



  • modemin icinde interface iplerini static işaretlebiliyorsun bazı modemlerde.

    yada sadece direk interface elle static e cevirebilirsin.

    ondan sonra sorun olmaz. aynı şekilde çalışan çok sistem biliyorum.

    kolay gelsin



  • Tşk ler üstadım sabah ilk iş denicem sonucu bildiririm. Saygılar.



  • Üstadım dediğin gibi yaptım modemin dhcp den verdiği ip leri squid custom optionsta yazdım
    lan1 wan1 den
    lan2 wan2 den çıktı sorunsuz. lakin pfsense wan bacaklarını static olarak işaretledim routing den 2 tane gateway tanımladım

    interface wan
    gateway adı wangw
    192.168.3.254 verdim wan interface ip yi.
    gateway ip de 192.168.1.1 verdim save dedim

    wan2 içinde aynı şeeyi yaptım

    firewall rulesten lan için wangw lan1 içinde wan1 gw seçtim

    pfsense kapatıp açtım sonuç sayfa açılmıyor hatası aldım. sanırım biyerlerde başka bi ayar yapmak lazım bunu static yapınca nedendir acaba nerde neyi eksik yaptım. saygılarımla.



  • Proxy (Squid) ayarlarında Allowed subnetse 2 lan subnetinide ekledinmi?
    10.0.0.0/24
    10.0.10.0/24

    şeklinde.



  • Onu eklememiştim bi deneyeyim. Fakat otomatik ip alinca nsıl çıkıyor benim anlamadığım o. Sonuçta gene ekli değil benim ip ler allowed subnette. Tplink modemde varmış dediğin özellik üstad. Dhcp yerine static seçtim modemden hep aynı ip verdi pfsense lan bacağına ama genede wan ve wan1 interfacelerini static çalıştırabilsem daha iyi istediğim ip numarasına sabitler geçerim.

    Saygılar.



  • ÜSTADIM SUBNETLERİ EKLEMEM RAĞMEN İNTERNETE ÇIKAMIYORUM NEDEN OLABİLİR ACABA BİR TÜRLÜ ÇÖZEMEDİM. SAYGILAR.



  • Merhaba.

    http://forum.pfsense.org/index.php/topic,56244.msg305545.html#msg305545

    burayi inceler misin

    @savasbilgitek:

    ÜSTADIM SUBNETLERİ EKLEMEM RAĞMEN İNTERNETE ÇIKAMIYORUM NEDEN OLABİLİR ACABA BİR TÜRLÜ ÇÖZEMEDİM. SAYGILAR.



  • İstersen lanı teke düşürüp dene bir.



  • Neyse modemden ip dhcp verdim reserve ettim o ip adresini pfsense makinesine her seferinde aynı ip veriyor. yalnız şöyle bir durum var team viewer dan sistemdeki herhangi bir pcye bağlanamıyorum artık id yazıyorum bağlan diyorum şifre soruyor şifreyi girip tmm diyorum öyle kalıyor karşı bilgisayarın ekranı gelmiyor
    neden olabilir acaba üstad bi ayar filanmı yapmak lazım team viewer için

    saygılar.


Log in to reply