ProxmoxVE 2.3 - LiveCD stops after boot menue



  • Hi,

    I am using Proxmox VE 2.3 on a Fujitsu TX120 S3 with Intel Xeon processor, 4GB RAM and 500GB SATA RAID1.
    I installed ProxmoxVE without any problems and I tried to install the latest pfsense 2.0.3 release and pfsense 2.1 amd64 snapshot (LiveCD .iso).

    The VM starts up but after the boot menu it stops. No matter if I use "Without ACPI" oder something else. What I can do I can use option 7 for the command shell.

    On another server hardware with ProxmoxVE pfsense installs so it seems to be a problem with the hardware.
    Any ideas where to look or what to change ?

    Thank your for your help!





  • Hi again,

    unfortunately I still get the same error with April-29 snapshot.

    Any idea what to change or test ?



  • Looks like I found the problem.

    I must disable "KVM Hardware Virtualization" on ProxmoxVE. I thought that the Intel Xeon E1220v2 can do all the Virtualization tecniques but it looks like it does not.



  • Unfortunately it's again me…

    I did some further tests - I installed Windows Server 2008R2 x64 on the same hardware as a VM. On this machine I can use "KVM Hardware Virtualization" enabled. Windows installs without problems. Further I can use the VirtIO drivers for NIC, HDD and ballooning.

    On pfsense 2.1 I modified the /boot/loader.conf.local like described here in the wiki:
    http://doc.pfsense.org/index.php/VirtIO_Driver_Support

    When running the following commands I get the same output as described on the wiki:

    • kldstat

    • df -h

    • swapinfo

    So the modules seems to be running, ballooning seems to work and the HDD driver seems to work. Even if the if_vtnet.ko is loaded I cannot use my NICs as VirtIO. If I revert back to E1000 on proxmox it is working. (Remember, on the same Proxmox Server I can use VirtIO for NICs on Windows).

    I followed the same pfsense doc instructions on another ProxmoxVM with different server hardware and all worked.

    So my questions are:
    Did I something wrong or could it be that FreeBSD 8.3 does not support the new server hardware I use and so some things like VirtIO for NICs is not supported ? Or is it something with Proxmox?

    I appreciate any help or hint :-)


Log in to reply