Captive portal lighttpd, evasive.silent=enabled doesn't work



  • I have read an article, it says

    "when mod_evasive turns a connection away, it creates an entry in the log file.
    to reduce disk write load and file size it would be neat to have a silent option where mod_evasive will not output anything.

    In my captive portal, maximum concurrent connections are 4. some clients automatically (maybe because of worm-virus-torrent) open many connections (above 4) per second , and i guess for that reason
    in the System Logs, I see "lighttpd[6729]: (mod_evasive.c.183) 10.210.0.97 turned away. Too many connections."..and these kind of lines are so much that can increase the size of logs so much.
    To prevent this, i added evasive.silent="enabled" in /etc/inc/system.inc..but lighttpd didn't start and gived the error below

    php[59417]: /services_captiveportal.php: The command '/usr/local/sbin/lighttpd -f /var/etc/lighty-CaptivePortal.conf' returned exit code '255', the output was 'Undefined config variable: var.true 2013-04-28 19:09:56: (configfile.c.943) source: /var/etc/lighty-CaptivePortal.conf line: 151 pos: 11 parser failed somehow near here: (EOL)'



  • try putting it at end of file in;
    /var/etc/lighty-ZONENAME-CaptivePortal.conf

    where ZONENAME is the name of CP zone to apply to.



  • I have been using pfSense 2.0.3 and in this version there are no zones.
    in /var/etc, lighty-Captiveportal.conf file exists.
    but as far as I know, captiveportal automatically creates lighty-CaptivePortal.conf file
    according to the settings on captiveportal.inc and system.inc… The settings about auto-creation of lighty-Captiveportal.conf file, exist in system.inc file
    for that reason I added the evasive.silent="enabled" line to the system.inc file....bu it didn't work and didn't recognize the evasive.silent
    @clart:

    try putting it at end of file in;
    /var/etc/lighty-ZONENAME-CaptivePortal.conf

    where ZONENAME is the name of CP zone to apply to.


Log in to reply