Web GUI hanging at SSL error



  • I've set up a lot of PFsense boxes with everything working fine, but I've ran into a strange error today.  This is a PFsense embedded install on an ALIX 2d13 board with 4gb CF.  All of the hardware is new out of the box.  Everything boots with no errors, I'm able to assign interfaces, assign IP addresses, etc. through the serial port. I connect to the LAN port to try to access the web GUI, click accept on the "SSL error" and it just hangs there and never gets to the login page.  It is not connected to anything and has no WAN connection atm.  This is only the initial install.

    I've tried:

    Flash the CF with an older version of PFsense.
    Re-flash with the current version of PFsense.
    Restart the webconfigurator.
    Use HTTP on the webconfigurator instead of HTTPs.
    Change the LAN IP and DHCP.
    I can ping the router on the LAN host.
    Retarted my machine and tried it on different machines.
    Tried to connect a WAN connection too.
    Tried running the commands:
    killall -9 php; killall -9 lighttpd; /etc/rc.restart_webgui

    All yield the same result.

    UPDATE: Plugged the CF into a different box, boots up fine and able to access the Web GUI, so this is obviously a hardware issue.  What could be failing?  They both have the exact same hardware.


  • Rebel Alliance Developer Netgate

    The most common thing to fail is the power supply. Did you try the same power supply on both units? Can you swap power supplies and see if the problem follows?

    If it seems to work otherwise, that is a bit of an odd place to stop, though it suggests that it's at least running the web server process but then PHP fails. Seeing the system log may help, but if it is hardware, it may not offer any real help, but it's still good to see.



  • Maybe this is the issue?  I don't know what this means.

    kernel: Trying to mount root from ufs:/dev/ufs/pfsense0
    kernel: WARNING: / was not properly dismounted
    kernel: WARNING: R/W mount of / denied. Filesystem is not clean - run fsck


  • Rebel Alliance Developer Netgate

    that means there is a problem with the filesystem, and it wasn't able to correct it with the filesystem check.

    If that happened "randomly" then it may be a faulty CF. Sometimes that happens if the power plug was yanked out (unclean shutdown) but it usually runs an automated check and can fix it.

    Wiping and re-imaging the CF, or better yet, a new CF, would eliminate that as a possible cause.



  • Didn't make much sense that the card with a "bad file system" worked on one board with the exact same hardware, but not this one.  So, I took a CF out of one of my known working PFsense boxes, put it into the box that was having the issue, that one wouldn't load the Web GUI either.  I ended up returning the ALIX board I had.  Still would be nice to know what was going on though.


  • Rebel Alliance Developer Netgate

    Difficult to speculate, probably a problem with the RAM, or perhaps the IDE controller.

    Did you try swapping the power supply (wall wart)?


Log in to reply