[SOLVED] Can ping but not mount SMB shares

  • Hey guys! Been working hard to learn and master this, but this seems to be the one thing I can't get.

    Here's my network setup:

    WORLD –--> Modem ---> PfSense ---> DDWRT (AP/Switch mode) ----> all my devices

    All DHCP is handled by pfsense with 192.168.1.X addresses.

    Here's the output of smbtree:

    	\\THEVAULT       		Drobo 5N (Samba V. 3.6.7)
    	\\RASPBERRYPI    		raspberrypi server
    		\\RASPBERRYPI\print$         	Printer Drivers
    		\\RASPBERRYPI\IPC$           	IPC Service (raspberrypi server)

    The Drobo (NAS) IP is The computer is However, trying to mount the share with cifs comes back with: "Unable to find suitable address."

    I also cannot mount the NAS anymore with my OSX of Windows machines. (OSX gives "The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again." messaging). Before I hooked up pfsense and had everything routed through ddwrt as a full router it worked fine.

    Can someone help me diagnose this? I can ping the NAS just fine, I can see it in smbtree. But I cannot mount it! What could be blocking it?

    Thanks so much!

  • I think I fixed it.

    On the LAN side, I had to set a pass rule for ports 445, 137-139 (in case any other pfsense noobs make the same mistake!)

  • You don't need any such rules, traffic between your internal machines never touches the firewall at all. Something else changed.

Log in to reply