Unable to connect to Warframe servers



  • Is anyone else having trouble with Warframe?  All of my other games play just fine.

    The game says that UPnP doesn't work correctly and tells me to open ports 3960 & 3962 to my machine.

    But when I look in the logs, I'm seeing connection requests from those ports, not to them.

    Any ideas how to fix things?

    Thanks.



  • It sounds like it's telling you everything you need to know.

    Do you have UPNP enabled?

    Services -> UPnP & NAT-PMP:

    Enable UPnP & NAT-PMP
    Allow UPnP Port Mapping



  • @marvosa:

    It sounds like it's telling you everything you need to know.

    Do you have UPNP enabled?

    Services -> UPnP & NAT-PMP:

    Enable UPnP & NAT-PMP
    Allow UPnP Port Mapping

    I've tried it with UPnP enabled and I still have the same problem.

    It doesn't work whether I use UPnP or manually forward the ports.



  • Post a network map /w IP's.

    Post your manual port forwards.



  • I changed my ports in the game to use 4998 and 4999 instead of the defaults.

    Firewall Rules
    WAN
    UDP  *  *  192.168.1.50  4998-4999  *  none

    Firewall NAT Port Forward
    WAN  UDP  *  *  WAN address  4998-4999  192.168.1.50  4998-4999



  • Ok, we got the port forward part… are we going to get the rest?

    Just so we rule out the obvious, have you disabled the windows software firewall?



  • @marvosa:

    Ok, we got the port forward part… are we going to get the rest?

    192.168.1.50 is my desktop that I'm attempting to play the game on.  It's wired to the LAN nic on the pfsense box.

    @marvosa:

    Just so we rule out the obvious, have you disabled the windows software firewall?

    Just tried that and same results.  netstat shows my machine listening on the correct UDP ports.



  • Fixed it.  Turned out I needed to set static ports.  I completely missed the sticky about that until just now.

    Thanks.



  • @Bai:

    Fixed it.  Turned out I needed to set static ports.  I completely missed the sticky about that until just now.

    Thanks.

    Can you please elaborate on this? I am having the same problem with Warframe but all other games seem to work fine.

    Thanks!



  • "Static ports" refers to having outbound nat set to manual and checking the box "static ports" in the outbound rule.

    By default the pfsense nat rules scramble the source port of outbound connections which can confuse some software which makes strange assumptions about which ports a connection is coming from.



  • @GruensFroeschli:

    "Static ports" refers to having outbound nat set to manual and checking the box "static ports" in the outbound rule.

    By default the pfsense nat rules scramble the source port of outbound connections which can confuse some software which makes strange assumptions about which ports a connection is coming from.

    Thank you for the reply. Kindly, I know what static ports are. I am more concerned about the details of his particular setup so that I can try it out for myself here. Thanks!



  • can someone please clarify this

    i am trying to make this work and already had conversations with the defs of the game because i cant get it to work

    "Static ports" refers to having outbound nat set to manual and checking the box "static ports" in the outbound rule.

    tried to put the rules there but it still does not work.

    thanks in advance



  • @Bai Shen

    would you mind posting a screenshot for this solution?
    we still encountered issues in warframe

    "Strict NAT detected. Upnp malfunctioning. Please forward  udp ports 4950 and 4955 to 192.168.1.32"

    i did this already:
    1. upnp enable (sevices>UPnp)
    2. select Manual Outbound NAT rule

    created 3 rules same below since we have 3dsl lines (in routing mode)
    interface: wan1/wan2/wan3
    source: 192.168.1.0/24
    source port: blank
    destination: any
    destination port: blank
    NAT address: default
    NAT port: blank
    Static port: CHECK

    thank you