Bump flowset buckets



  • Hi All,

    Previously I have pfSense 2.0.1-Release (i386) installed as a vm in VMware 4.1.0 with 2 vCPU and 4GB RAM. Recently I have migrated my pfSense to VMware 5.1.0 and upgraded to 4 CPU and 8GB RAM. After successfully powering my pfSense 2.0.1 RC1 (i386) on the new vmware server, I proceed to upgrade pfSense to 2.0.3-Release (i386).

    I tried to use Traffic Shaper but when I check in my vmware console, the console is showing
    Bump flowset buckets to 64 (was 0)

    Checking in /var/log/syslog, I got these errors:
    Jun  4 17:28:19 fw01 syslogd: sendto: No buffer space available
    Jun  4 17:28:19 fw01 syslogd: sendto: No buffer space available

    This is the /boot/loader.conf
    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="0"
    kern.hz=100vmblock_load="YES"
    vmmemct_load="YES"
    vmhgfs_load="YES"
    vmxnet_load="YES"

    This is the /etc/sysctl.conf

    $FreeBSD: src/etc/sysctl.conf,v 1.8.34.1.4.1 2010/06/14 02:09:06 kensmith Exp $

    #  This file is read when going to multi-user and its contents piped thru
    sysctl'' to adjust kernel values.man 5 sysctl.conf'' for details.

    Uncomment this to prevent users from seeing information about processes that

    are being run under another UID.

    #security.bsd.see_other_uids=0

    Can anybody tell me what is the "Bump flowset buckets to 64" means? What setting do I need to look into?

    Should I look into adjusting the vm.kmem_size and vm.kmem_size_max value? What value should I set for the vm.kmem_size and vm.kmem_size_max?
    I read that FreeBSD 8.1 kernel is able to auto-adjust the value but it does not seem to be using the full memory I have given to the system.

    Would anyone be able to help?

    Thanks & Regards.



  • Hi All,

    I installed a vm using the pfSense 2.0.3-Release i386 for testing.
    I tried to change the vm.kmem_size to 1GB and vm.kmem_size_max to 2GB but after that the pfSense cannot boot and I got this error:
    KDB: debugger backends: ddb
    KDB: current backend: ddb
    1048576K of memory above 4GB ignored
    panic: kmem_suballoc: bad status return of 3
    cpuid = 0
    KDB: enter: panic