Interface(opt3) does not redirect to portal



  • okay, so i have pfsense as the main gateway for all my subnets

    WAN  - Internet
    LAN   - Where my server resides..
    OPT2 - where other server resides..
    OPT3 - Wifi (Vlan 10)
    OPT4 - Desktop (Vlan 20)

    so its all well routed, and its working fine. my only issue is when i create a captive portal for my OPT3 - Wifi interface.

    I uploaded a simple .html file (just to test if the page will load..) (and im certain .html is uploaded, i can view it when i click 'view current page')

    when i browse, it does not redirect at all to the portal page
    wall gardening is working, i can ping OPT3 gateway which is (192.168.10.1)

    I cannot ping any hosts pass my interface gateway.

    below are the only parameters i toggled

    First setting:

    Enable Captive Portal
    Selected OPT3 as interface
    No Authentication
    –--------------------------------
    Second Setting:

    Enable Captive Portal
    Selected OPT3 as interface
    No Authentication
    Upload .html file

    in my firewall rules > opt3
    my setting is any any

    can you clarify if this is a bug?



  • 30 Views and no help :(



  • @pedenski:

    when i browse, it does not redirect at all to the portal page

    Browse to where? There is a known strangeness if the browser starts with a https page but I don't recall the details.

    @pedenski:

    wall gardening is working, i can ping OPT3 gateway which is (192.168.10.1)

    I don't understand the term "wall gardening".

    I have only ever used captive portal with authentication. What are you trying to do with captive portal and no authentication?

    Which build of pfSense are you using? If I recall correctly, in some circumstances in "older" versions of pfSense a kernel module required by captive portal didn't get loaded. Did you apply (to running system) after enabling Captive Portal? If not, did you reboot?



  • Just add your DNS servers to "allowed ip addresses" in captive settings.



  • @nothing:

    Just add your DNS servers to "allowed ip addresses" in captive settings.

    I can confirm that this is probably the problem.

    /erik


Log in to reply