Mail Server behind pfsense



  • I have installed pfsense 2.0.3 release to act as a firewall but am I cannot receiving emails. pfsense sits after a dlink router and the mail server sits after pfsense as shown:  Router - pfsense - mail server
    port forwarding (25,110,80) is done on the router.

    How do I allow smtp traffic reach the mail server



  • What do you have configured on your pfSense box?  You'll need rules on the WAN interface to allow your desired ports to the mail server, or since your pfSense sits on your local network, you could do a static NAT and create an IP address for your mail server on your local network.  Not sure if/what firewall rules would be needed in that instance.  Don't forget to also add rules to your LAN interface to allow your mail server to send mail back out.



  • Why not pass all traffic through the router and let pfSense do all the routing? Is there a reason why you cannot so this?



  • Mpreissener,

    I have done static NAT (port 25,110) on the Pfsense although this has also be done on the router, I have also allowed port 25 traffic on the pfsense WAN interface and LAN interface.

    Am able to send mails but I cant receive



  • @drzoidberg33:

    Why not pass all traffic through the router and let pfSense do all the routing? Is there a reason why you cannot so this?

    Or even take the dlink out completely?

    But-  are you pointing the forwarded traffic out of the dlink to the pfsense box?



  • If I get the situation right, you could improve your current situation, if you

    1.) remove the dlink (see chpalmer) and use a simple modem instead or
    2.) operate the dlink as a modem only (if possible, don't know the exact model) in bridge mode and let pfSense establish internet connection or
    3.) disable NAT on pfSense to avoid double NAT with dlink. Define NAT rules on the dlink and corresponding firewall rules on the pfSense machine: http://doc.pfsense.org/index.php/How_can_I_completely_disable_NAT%3F#Disable_NAT

    Peter