Warframe Port Forwarding



  • Every time I log into this game called Warframe I get a error message saying I have strict NAT and that I need to port forward 3960 & 3962 to my local address. I have UPnP disabled in the game because it wasn't working even with UPnP completely unblocked in the firewall settings. I have port forwarded correctly as far as i know. When i run servers for other games through those ports the servers work fine, Yet Warframe is still having issues with NAT. I ran my internet directly to my computer to check if it was the firewall's problem and Warframe had open NAT with the direct internet connection. Is there anything else that i might need to do, check, or change? Thanks for the help ahead of time.





  • Turns out it's a networking glitch in the game, I'm good.



  • Do you have NAT rules set up or are you just using uPnP?



  • I have both.



  • The game is still in beta.  It's gotta be an issue with their code.  I tried it myself with the appropriate port forwards in place and still got the message… it's an issue with the game.

    Even though you get that message...it still lets you play... hopefully they fix that in the final release.



  • @marvosa:

    The game is still in beta.  It's gotta be an issue with their code.  I tried it myself with the appropriate port forwards in place and still got the message… it's an issue with the game.

    Even though you get that message...it still lets you play... hopefully they fix that in the final release.

    Actually, it's a pfSense setting.  See the thread I started.

    http://forum.pfsense.org/index.php?PHPSESSID=da98598fd56f585720c2477d9ccb7bfb&topic=62475.0

    Basically you need to set static ports as explained here.

    http://doc.pfsense.org/index.php/Static_Port



  • I recently launched this game again to see whats up with it and noticed that it's still complaining about upnp not working, but now it does actually make the port forwards when I check upnp status on pfSense. So the game is still bugged out, but it works even than it complains about NAT.



  • I know this thread is really old, but it can be easily found via google (keywords: warframe pfsense port forward)

    Since the problem continues to exist (warframe network code still needs static ports for the forward), I'll post my working configuration of my pfsense version 2.2.2.

    Warframe ingame config
    I'm using the ports 4950 and 4955 both udp.
    Screenshot: http://i.imgur.com/xxqDvrY.png

    pfsense - Firewall: NAT: Port Forward
    Add 2 Rules, in my case juno_home is just an alias for my internal IP address of the PC I play Warframe on (ex. 192.168.1.20).

    
    If        Proto     Src. addr    Src. ports     Dest. addr       Dest. ports    NAT IP       NAT Ports       Description
    WAN       UDP       *            *              WAN address      4950           juno_home    4950            Warframe        
    WAN       UDP       *            *              WAN address      4955           juno_home    4955            Warframe 
    
    

    Screenshot: http://i.imgur.com/g1Oecyl.png

    pfsense - Firewall: NAT: Outbound
    In the outbound tab of the NAT menu, set the mode to (Hybrid is available since version 2.2.2):

    
    Hybrid Outbound NAT rule generation
    (Automatic Outbound NAT + rules below) 
    
    

    Also 2 new mappings:

    
    Interface   Source       Source Port    Destination    Destination Port    NAT Address       NAT Port       Static Port       Description       
    WAN         juno_home    udp/4950       *              udp/*               WAN address       4950           NO                Warframe static Ports needed        
    WAN         juno_home    udp/4955       *              udp/*               WAN address       4955           NO                Warframe static Ports needed 
    
    

    Screenshot: http://i.imgur.com/FlAKNVj.png

    Important: Using the checkbox "Static Port" in the NAT: Outbound mapping will not work.

    Benefits by doing all this:

    • You'll keep your random ports (good for privacy on the internet)

    • You can disable UPnP and NAT-PMP in pfsense

    • You can disable UPnP and NAT-PMP in warframe

    cya,
    Chanz