Does OpenVNP always become default route? Is there a way to avoid that?



  • When I establish an OpenVPN connection, my routing table becomes like one attached.

    I want my WAN to be the default gateway and OpenVPN to be used for access to a few predefined servers.

    However two very strange routing rules appear after connection is established. The destinations are 0.0.0.0/1 and 128.0.0.0/1 and they go through OpenVPN.

    In the screenshot my WAN gateway is the default gateway, but any connection goes through OpenVPN anyway.

    Is that by design?

    Can I leave the OpenVPN connection up, but drop these routes?
    ![Google Chrome.png](/public/imported_attachments/1/Google Chrome.png)
    ![Google Chrome.png_thumb](/public/imported_attachments/1/Google Chrome.png_thumb)


  • Banned

    Uhm… stop enabling redirect gateway on the OVPN server? :D The above is caused by --redirect-gateway def1



  • Solved by adding "route-nopull" to advanced options.



  • @antonio7:

    Solved by adding "route-nopull" to advanced options.

    Can you tell me where did you put "route-nopull"? I've got the very same problem. Unfortunately I am pfsense newbie and I am not sure where to put this "route-nopull"…



  • The OpenVPN client settings GUI page, Advanced Options box - that can take anything that is valid to add to an OpenVPN conf file - like route-nopull
    Just type it without quotes - it will be appended directly to the client conf file.