CP not redirecting to port 8000!



  • I have a CaptivePortal which is not redirecting…everything is ok.
    Traffic gets funneled to the LAN interface port 80.. However, it just doesn't show up at port 8000!

    ipfw counters doesn't seem to be updated!
    Landing page comes up fine when the browser is pointed to port 8000, just that traffic doesn't get redirected to port 8000 automatically!

    65291 0 0 allow pfsync from any to any
    65292 0 0 allow carp from any to any
    65301 0 0 allow ip from any to any layer2 mac-type 0x0806,0x8035
    65302 0 0 allow ip from any to any layer2 mac-type 0x888e,0x88c7
    65303 0 0 allow ip from any to any layer2 mac-type 0x8863,0x8864
    65307 0 0 deny ip from any to any layer2 not mac-type 0x0800,0x86dd
    65310 0 0 allow ip from any to { 255.255.255.255 or 10.10.200.10 } in
    65311 0 0 allow ip from { 255.255.255.255 or 10.10.200.10 } to any out
    65312 0 0 allow icmp from { 255.255.255.255 or 10.10.200.10 } to any out icmptyp
    es 0
    65313 0 0 allow icmp from any to { 255.255.255.255 or 10.10.200.10 } in icmptype
    s 8
    65314 0 0 pipe tablearg ip from table(3) to any in
    65315 0 0 pipe tablearg ip from any to table(4) in
    65316 0 0 pipe tablearg ip from table(3) to any out
    65317 0 0 pipe tablearg ip from any to table(4) out
    65318 0 0 pipe tablearg ip from table(1) to any in
    65319 0 0 pipe tablearg ip from any to table(2) out
    65532 0 0 fwd 127.0.0.1,8000 tcp from any to any dst-port 80 in
    65533 0 0 allow tcp from any to any out
    65534 0 0 deny ip from any to any
    65535 0 0 allow ip from any to any

    Please help!
    /wai-sun



  • Replying to my own post:
    Turned out that indeed the layer 2 filtering was turned off!

    The culprit is: net.link.ether.ipfw!!!
    Once turned on:
                            sysctl net.link.ether.ipfw=1
    Everything just started working!
    The question is:
    Do I need to put this is /etc/sysctl.conf?

    /wai-sun