Lan Client için Wan ip adresi değiştirme



  • Öncelikle Herkese Merhaba,

    Süperonline Fiber kullanıyoruz, 14 dış ip adresimiz var. Firewall: Virtual IP Addresses kısmında bu ip adreslerimizi tanımladık.
    Örnek veriyorum Dışarıdan X wan ip adresimize gelen 1500 port isteklerini içeride x ip adresine gönder şeklindeki tanımlamarı Firewall: NAT: Port Forward bölümünden oluşturduk sorun yok.
    Sıkıntı içerideki X bir client'ın internet çıkışındaki Wan ip adresini ayarlama.
    yani ahmet'in bilgisayarı bize verilen 14 ip içerisinden X ip den çıkış yapsın, mehmetse Y ip adresinden çıkış yapsın…

    Herkese şimdiden teşekkür ediyorum



  • @kadelus:

    Öncelikle Herkese Merhaba,

    Süperonline Fiber kullanıyoruz, 14 dış ip adresimiz var. Firewall: Virtual IP Addresses kısmında bu ip adreslerimizi tanımladık.
    Örnek veriyorum Dışarıdan X wan ip adresimize gelen 1500 port isteklerini içeride x ip adresine gönder şeklindeki tanımlamarı Firewall: NAT: Port Forward bölümünden oluşturduk sorun yok.
    Sıkıntı içerideki X bir client'ın internet çıkışındaki Wan ip adresini ayarlama.
    yani ahmet'in bilgisayarı bize verilen 14 ip içerisinden X ip den çıkış yapsın, mehmetse Y ip adresinden çıkış yapsın…

    Herkese şimdiden teşekkür ediyorum

    Lütfen daha önce bu tür konular açılmış mı önce araştırma yapınız.

    System > Routing > Gateways

    buradan tanımlayacağınız gatewayleri de

    Firewall > Rules > (LAN) kısmından kural eklerken Advanced features kısmından gateway belirterek istediğiniz ip den çıkış yapmasını sağlayabilirsiniz ( ayrıca Firewall > Aliases kısmından grup tanımlayıp bunları grup olarak ta gateway atayabilirsiniz )

    iyi çalışmalar.



  • ilginiz için tekrar teşekkür ederim fakat Fourmda biraz araştırdım bir konu buldum fakat sonunda çözüldü diyip alakasız bir konuya gidiyor malesef.
    http://forum.pfsense.org/index.php/topic,38607.0.html

    Gatewaylerimi oluşturdum. Firewall Rules - Lan dan kurallarımı tanımladım fakat sonuç değişmedi.

    yine ısrarla tanımladığım pc default wan adresinden çıkış yapıyor.
    farklı pc'ler de denedim. sonuç aynı.

    acaba firewall nat' ta da bir yönlendirmemi yapmamız gerek, veya bir ayar mı var ne tanımlanırsa tanımlansın her zaman wan ip adresini kullan diye?



  • Pfsense'te squid ve squidguard kurulu. Bunun bir etkisi varmıdır onuda bilmiyorum.
    bir dökümanda system-advanced-firewall sayfasındaki Disable NAT Reflection for 1:1 NAT 'ın uncheck olması gerektiğini yazmış onuda denedim fakat sonuç yine değişmedi.
    Firewall: NAT: Outbound bölümünde de mapping oluşturdum oda işe yaramadı malesef.



  • Çözüldü.
    firewall rules ile bir ilgisi yokmuş.
    Firewall: NAT: 1:1 ve Firewall: NAT: Port Forward ile çözdüm.



  • Geri bildirim için teşekkürler, sorununuzun çözüldüğüne sevindim.



  • Ben teşekkür ederim. Çözümü daha açıklamak gerekirse  Firewall: NAT: Port Forward ilede bir alakası yokmuş. Firewall: NAT: 1:1  ile yönlendirme yapılması gerekiyormuş. Aslında bende ilk olarak bu yöntemi denedim ama çalışmadı. Çalışmamasının nedeni de sistemde squid ve squidguard kurulu. Dolayısıyla tüm 80 portlarım squid üzerinden geçiyor. Firewall: NAT: 1:1 ayarlarından Client pc ye ne kadar yönlendirme yapsamda dış ip adresi squid'in ip
    adresi oluyor. Çözüm olarakta "Proxy server: General settings" /  "Bypass proxy for these source IPs" bölümünde wan ip sini ayarladığım pc'nin ip adresini yazarak squid (Proxy server) sistemine dahil etmedim.