Openvpn client getting IP, not getting a gateway



  • I've seen a few posts on this topic but still not 100% sure on why there are config differences between an IOS config using openvpn connect and the exported windows openvpn installer for the client.  I can use the openvpn config exporter to export a config for IOS and it works fine.  If I export the exact same config for a windows installer package it does not work - I don't get a default gateway pushed to the windows PC and therefore no connectivity.  I will add a push route to the server this weekend which should solve for the PC client connect issues but may create a new issue with my IOS connectivity - we'll see.

    Any thoughts from more advanced users on why this issue may exist on one client platform but not on another?  Thx



  • OK - I was at the remote pfsense box today and added the push route in the advanced options.  Still no luck the openvpn log states "route addition failed using CreateIPForwardEntry: The object already exists".  So, my win 7 openvpn client still gets no gateway and while I can connect to the lan I cannot get out to the internet.  Yet, this same config still works perfect for my IOS device with openvpn connect app.  Any thoughts?



  • My guess is that you didn't install the openvpn client package in windows as admin.
    When you install the package, you have to right click, run as admin and accept all the following dialogue boxes.
    I also make a habit of right click and running the openvpn gui as admin even after install, but its not required.

    If you are not sure that you installed as admin, please uninstall openvpn completely and and then reinstall with the right - click run as admin.
    I also use TUN usually and not TAP so much.  If you have other VPN solutions installed along side openvpn, those can also cause issue.

    (windows firewall or any firewall can also break things - Might want to deactivate those during troubleshooting)