Проблемы с установкой стронних пакетов 2.0.3



  • Товарищи, может кто сталкивался и подскажет. При установке mc или quagga с http://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/Latest/
    Пакеты устанавливаются, но выдают предупреждение о том, что версии package libiconv gettext необходимые им для работы отличаются от установленных.
    При попытке старта программы выдаётся сообщение  /libexec/ld-elf.so.1: /usr/local/lib/libgcrypt.so.19: Undefined symbol "_ThreadRuneLocale
    Заметил, что на LIVE-CD pfSense 2.0.3 есть файл pkg_info.txt c вот таким содержимым bsdinstaller-2.0.2013.0412 BSD Installer mega-package gettext-0.18.1.1    GNU gettext package libiconv-1.14 A character set conversion library.

    Может это конечно никак не связано, но есть у меня такое подозрение.

    А вопрос как заставить работать проги?! Особенно quagga/



  • Версию для 8.3 ищите, если мне память не изменяет именно она в pfSense 2.0.3.



  • 2.0.3-RELEASE (amd64)
    built on Fri Apr 12 10:27:56 EDT 2013
    FreeBSD 8.1-RELEASE-p13

    Вот что написано в Даше pfSense. Вроде как 8.1



  • ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/
    

    отсюда пробуйте ставить
    quagga есть в pfSense packages



  • @nemisis:

    Вот что написано в Даше pfSense. Вроде как 8.1

    Да. Сори, ошибся.



  • в версии i386 ставил пакеты залитые c ftp.freebsd.org
    брал отсюда => /pub/FreeBSD/ports/i386/packages-8-stable/
    mc и компания работали на ура



  • У меня тоже выскакивала такая ошибка. Пробовал пакеты закидывать через веб интерфейс, разные репозитории, мне почему-то Ftpшники попадались не рабочие с 8.1 версией, а на других вылитали ошибки. А потом нашел нашел который подошел.
    Делаем так: 
    в переменную окружения загоняем ftp
    setenv PACKAGESITE http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/uname -m/packages-8.1-release/Latest/
    а потом спокойно ставим пакеты, например
    pkg_add -r unzip


Log in to reply