Point d'accès WIFI



  • J'ai un soucis à configurer ma machine sous pfsense en tant que point d'accès WIFI.

    Voici ma configuration :
    Le hardware vient de chez pcengine.ch, c'est un wrap avec 3 port RJ45 et une carte Wireless Atheros 200mW. J'ai mis à jour le BIOS à la version 1.11 qui supporte la carte Wireless.

    J'ai installé pfsense, version Beta 1.0 d'y a 2 jours.

    Ma connexion internet adsl fonctionne correctement depuis, pfsense obtient une adresse ip de mon fournisseur d'accès.

    Afin d'obtenir du réseau sans fil j'ai fait la configuration suivante :
    Ajouter ma carte Atheros OPT1, j'ai changé son nom en WLAN

    Je l'ai bridger avec l'interface LAN, réglé la puissance d'émission au max et je pensais voir le tout fonctionner.
    Je met mon portable en route, allume le réseau sans fil. Je vois le réseau, je peux m'y connecter (pas de protection pour le moment).
    Impossible d'obtenir une adresse IP par le DHCP. Je met une adresse IP fixe et là j'ai accès au routeur.

    J'ajoute la même règle sur l'interface WLAN que sur la LAN qui autorise l'accès en sortie. A ce moment là j'ai accès à Internet avec mon adresse IP fixe. Je tente de passer en DHCP, mais toujours pas d'adresse obtenue. Je vais un autre essai avec une machine sous MacOS X, identique.

    Est-ce qu'il y a un paramètre particulier à régler pour laisser passer le DHCP ?



  • Il me semble avoir trouvé une solution qui permettre d'obtenir une adresse IP via le serveur DHCP de mon routeur pfsense.

    J'ai simplement ajouté un nom dans l'option suivante de mon interface WLAN qui est bridgée avec mon interface LAN :

    • DHCP client configuration

    Voilà.



  • Après encore quelques tests, j'ai pu constaté que le paramètre entré dans le champ DHCP client configuration n'est pas enregistré par le système. J'arrive à obtenir temporairement une adresse DHCP au travers du réseau WIFI.

    Est-ce que quelqu'un à un système en place avec une carte WIFI qui fonctionne ? ou suis-je le seul dans ce cas ?

    Je vais faire la mise à jour à la dernière version qui est à disposition sur la page de monsieur Ullrich.



  • Bonjour,

    il semble que l'on soit dans une config similaire. Peux tu me dire où tu en est?

    D'avance merci.

    Nusa



  • Je n'ai plus rien retouché. Je vais tenter de mettre à jour avec un version plus récente et faire un essai pour voir ce qu'il se passe.

    Bonne journée.


Locked