BUG 2.0.3-RELEASE-pfSense field can be used to modify ("spoof") the MAC address



  • Field can be used to modify ("spoof") the MAC address in the device cause a bug!
    The device is associated but not the IP from the DHCP of the AP.

    urtw0: rtl8187l

    If leave blank the field the dhcp work.(The first time,otherwise i need to copy and paste my original MAC address or reboot).

    ##########################WORK#########################################
    ###########################################################################

    
    urtw0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether **:**:**:**:**:**
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
    urtw0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether e8:4e:06:05:49:2b
            inet6 **::**:**:**:**%urtw0_wlan0 prefixlen 64 scopeid 0x8
            inet 192.168.26.7 netmask 0xffffffff broadcast 192.168.26.7
            nd6 options=43 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
            ssid Test channel 2 (2417 MHz 11g) bssid 00:17:c2:44:d2:37
            country US authmode OPEN privacy OFF txpower 0 bmiss 7 scanvalid 60
            bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 5
            protmode RTSCTS</performnud,accept_rtadv></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast>
    

    manual change the mac adress

    ifconfig urtw0 ether 02:0a:51:65:41:f9

    ##########################NOT WORK#####################################
    ###########################################################################

    urtw0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 02:0a:51:65:41:f9
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
    urtw0_wlan0: flags=8c43 <up,broadcast,running,oactive,simplex,multicast>metric 0 mtu 1500
            ether 02:0a:51:65:41:f9
            inet6 *::*:**:**:**%urtw0_wlan0 prefixlen 64 scopeid 0x8 <--- inet6 grab the original MAC???
            inet 192.168.26.7 netmask 0xffffffff broadcast 192.168.26.7
            nd6 options=43 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: no carrier
            ssid Test channel 6 (2437 MHz 11g)
            country US authmode OPEN privacy OFF txpower 0 bmiss 7 scanvalid 60
            bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 5
            protmode RTSCTS</performnud,accept_rtadv></up,broadcast,running,oactive,simplex,multicast></up,broadcast,running,simplex,multicast> 
    

    the AP recognize but not associated

    dmesg

    urtw0_wlan0: ieee80211_new_state_locked: pending ASSOC -> RUN transition lost
    
    



  • Banned



  • With zeroshell work all my 4 rtl8187l with MAC changes i have lost days and night to force change mac address,
    after change the mac address in pfsense the AP has the original mac in list!!! Is impossible!Imo lastly buged driver (urtw)or script!



  • There may be a bug with MAC address handling for the *_wlan0 interfaces that may have gone unnoticed by everyone else and that I never got around to fixing myself.  Rather than assigning urtw0 directly; if it is still assigned to something, then unassign it and reboot (also reboot if you haven't since it was last assigned), or instead of rebooting you can delete the urtw0_wlan0 interface manually from the console if you know how; then create a virtual wireless interface on the wireless tab (available from the assign interfaces page) and assign urtw0_wlan1 instead or directly assigning urtw0.  If the bug I'm thinking of is still there, this may work around it.


Log in to reply