HDD Crashing or Something Else?



  • I am running 2.0.3 64bit installed onto a 50GB "enterprise" micron ssd. The board is a Via EPIA M910-10E. This is the dual core fanless Nano processor. I did the full install. No problems for 5 months or so. Now however my dhcp stops working and I go to the machine and I get a slew of errors. (gfs_vfs_done():ad5s1a[WRITE(offset=29474504704, lenth=16382)] error = 6). There are a slew of other messages relating to ad5s1a and write errors. I have pictures of the full screen. I could reboot it a couple of times and it would come back working. However after a time it would hang and not boot anymore.

    I thought my ssd(intel 311 SLC) had gone bad so I replaced it with a "enterprise" micron drive. It had been fine for about 2 or 3 weeks then same types of errors. I then changed out the motherboard thinking the hdd controller was bad. I then proceeded to do a fresh install. Probably for about 6 weeks no issue. Then last night it popped again, this morning it was stuck and wouldn't reboot. I just wiped the drive and reinstalled a fresh version then restoring my backup config.

    The only thing I changed this time was the sata cable hoping maybe it was bad.

    Any thoughts on these problems? Is this specific to something with the VIA sata controller? Should I be doing a different type of install than a full install like on a regular harddrives? Possibly going to the 32 bit version would fix this or to the 2.1RC? I am open to suggestions. Thanks for any help. If anyone needs to see the pictures I am more than happy to send them along if they would help.



  • Can you go to diagnostic > smart status

    Select all in that first drop down

    Then click view and paste here?

    I'd be interested to see what is there.

    (It would be nice to see that for your Intel drive also)



  • I'm sure you tried the below but just in case…

    You didn't mention if you tested / changed the RAM.  I had a server (not pfSense) and RAM worked great for 8 months, them BAM it started spitting errors of lockups, reboots, etc.  After running a MemTest app it showed errors in less than 10 seconds.  Replaced RAM (after testing) and unit was solid again.

    Another item to check is the power supply.  How reliable is it?  Are you REALLY sure?  These two items can drive you insane if either or both are (intermittent) problems.

    Hopefully you find your issue and report back so others will gain from it.

    Good luck!



  • Yeah - Because an Intel SLC SSD is pretty freakin durable.  Thats why I wanted to see what smart said about it.



  • I remember reading some of the early SSDs would sometimes "go away" for a "long" time (tens of seconds or more) possibly to do management functions like wear levelling. The "absence' resulted in access timeouts.Do your write errors begin with a timeout?



  • Mine hasn't gone on vacation so far - The first time it does, I'm pulling it and popping the HDD back in.
    BTW - I guess we won't be seeing that SMART status.  Must be topsecret - G4.



  • Sorry, long weekend. An update on the status of the drive/installation. As I stated before I changed the sata cable before booting it back up. Running through the weekend showed no problems. This is good as before I left, it felt like an imminent total crash was inevitable. I have captured the smart data this morning from the micron drive. Sorry I don't have one for the Intel drive. It is hard to shut the router down without messing with someone at the office.

    Regarding swapping out the ram, that is something that completely slipped my mind. I am going to order another set immediately and have it ready the next issue we have. Thank you for bringing that up. In regards to the power supply, it is a seasonic 1u supply and I felt more comfortable with it than any other 1u supply. Now however I am in doubt there as well. If the cable and then ram prove to not to correct the issue, I will move to the power supply.

    So I assume since we are going with regular troubleshooting techniques, people haven't experienced issues specifically caused by VIA sata controllers. So no known issue there. A cable being bad is a rare occurrence,  but hopefully in my case that will be the case. This should mean my trusty Intel 311 is still good to go.

    As requested my smart logs from the micron "enterprise" drive:

    smartctl 6.0 2012-10-10 r3643 [FreeBSD 8.1-RELEASE-p13 amd64] (local build)
    Copyright (C) 2002-12, Bruce Allen, Christian Franke, www.smartmontools.org

    === START OF INFORMATION SECTION ===
    Device Model:    Micron_P400e-MTFDDAK050MAR
    Serial Number:    12010356C155
    LU WWN Device Id: 5 00a075 10356c155
    Firmware Version: 0152
    User Capacity:    50,020,540,416 bytes [50.0 GB]
    Sector Size:      512 bytes logical/physical
    Rotation Rate:    Solid State Device
    Device is:        Not in smartctl database [for details use: -P showall]
    ATA Version is:  ACS-2, ATA8-ACS T13/1699-D revision 6
    SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
    Local Time is:    Tue Sep  3 09:05:10 2013 CDT
    SMART support is: Available - device has SMART capability.
    SMART support is: Enabled

    === START OF READ SMART DATA SECTION ===
    SMART overall-health self-assessment test result: PASSED

    General SMART Values:
    Offline data collection status:  (0x80) Offline data collection activity
    was never started.
    Auto Offline Data Collection: Enabled.
    Self-test execution status:      (  0) The previous self-test routine completed
    without error or no self-test has ever
    been run.
    Total time to complete Offline
    data collection: (  230) seconds.
    Offline data collection
    capabilities: (0x7b) SMART execute Offline immediate.
    Auto Offline data collection on/off support.
    Suspend Offline collection upon new
    command.
    Offline surface scan supported.
    Self-test supported.
    Conveyance Self-test supported.
    Selective Self-test supported.
    SMART capabilities:            (0x0003) Saves SMART data before entering
    power-saving mode.
    Supports SMART auto save timer.
    Error logging capability:        (0x01) Error logging supported.
    General Purpose Logging supported.
    Short self-test routine
    recommended polling time: (  2) minutes.
    Extended self-test routine
    recommended polling time: (  3) minutes.
    Conveyance self-test routine
    recommended polling time: (  3) minutes.
    SCT capabilities:       (0x003d) SCT Status supported.
    SCT Error Recovery Control supported.
    SCT Feature Control supported.
    SCT Data Table supported.

    SMART Attributes Data Structure revision number: 16
    Vendor Specific SMART Attributes with Thresholds:
    ID# ATTRIBUTE_NAME          FLAG    VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
      1 Raw_Read_Error_Rate    0x002f  100  100  050    Pre-fail  Always      -      0
      5 Reallocated_Sector_Ct  0x0033  100  100  010    Pre-fail  Always      -      0
      9 Power_On_Hours          0x0032  100  100  001    Old_age  Always      -      630
    12 Power_Cycle_Count      0x0032  100  100  001    Old_age  Always      -      16
    170 Unknown_Attribute      0x0033  100  100  010    Pre-fail  Always      -      0
    171 Unknown_Attribute      0x0032  100  100  001    Old_age  Always      -      0
    172 Unknown_Attribute      0x0032  100  100  001    Old_age  Always      -      0
    173 Unknown_Attribute      0x0033  100  100  010    Pre-fail  Always      -      0
    174 Unknown_Attribute      0x0032  100  100  001    Old_age  Always      -      14
    181 Program_Fail_Cnt_Total  0x0022  100  100  001    Old_age  Always      -      206161510401
    183 Runtime_Bad_Block      0x0032  100  100  001    Old_age  Always      -      0
    184 End-to-End_Error        0x0033  100  100  050    Pre-fail  Always      -      0
    187 Reported_Uncorrect      0x0032  100  100  001    Old_age  Always      -      0
    188 Command_Timeout        0x0032  100  100  001    Old_age  Always      -      0
    189 Unknown_SSD_Attribute  0x000e  100  100  001    Old_age  Always      -      52
    194 Temperature_Celsius    0x0022  019  027  000    Old_age  Always      -      19 (Min/Max 19/27)
    195 Hardware_ECC_Recovered  0x003a  100  100  001    Old_age  Always      -      0
    196 Reallocated_Event_Count 0x0032  100  100  001    Old_age  Always      -      0
    197 Current_Pending_Sector  0x0032  100  100  001    Old_age  Always      -      0
    198 Offline_Uncorrectable  0x0030  100  100  001    Old_age  Offline      -      0
    199 UDMA_CRC_Error_Count    0x0032  100  100  001    Old_age  Always      -      33
    202 Unknown_SSD_Attribute  0x0018  100  100  001    Old_age  Offline      -      0
    206 Unknown_SSD_Attribute  0x000e  100  100  001    Old_age  Always      -      0
    242 Total_LBAs_Read        0x0002  100  100  001    Old_age  Always      -      17705

    SMART Error Log Version: 1
    No Errors Logged

    SMART Self-test log structure revision number 1
    No self-tests have been logged.  [To run self-tests, use: smartctl -t]

    SMART Selective self-test log data structure revision number 1
    SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
        1        0        0  Not_testing
        2        0        0  Not_testing
        3        0        0  Not_testing
        4        0        0  Not_testing
        5        0        0  Not_testing
    Selective self-test flags (0x0):
      After scanning selected spans, do NOT read-scan remainder of disk.
    If Selective self-test is pending on power-up, resume after 0 minute delay.



  • Well - This is maybe a tad high:

    181 Program_Fail_Cnt_Total  0x0022  100  100  001    Old_age  Always      -      206161510401

    Mine is pretty close to this:

    181 Program_Fail_Cnt_Total  0x0032  100  100  010    Old_age  Always      -      0

    But I'm not sure that means anything

    But this one here might indicate a bad SATA cable or port:

    199 UDMA_CRC_Error_Count    0x0032  100  100  001    Old_age  Always      -      33

    I managed to cause 1 of those in my own drive by cutting the power suddenly, but you have a few.  I'm thinking bad cable.



  • Bad thing is this is with a different motherboard(new port) and a new sata cable.



  • I'd be inclined to believe that both drives are good…

    However, if testing the Intel drive is a bother, you can send it to me FEDEX and I will test it for you for 5 or 10 years and let you know the results.

    On a more serious note, I keep my drive health info in a flat-file so that I can check the current values against older values to see if there are very noticeable changes.  Interesting though - I've never had a bad SATA cable.



  • The only time I have ever heard of a bad hdd cable (pata or sata) has been when pc magazine or someone like that intentionally damaged a cable to see if 5 repair places would properly diagnose it.

    At this point it is way too early to tell if changing the cable helped, and looking at the smart report there are a lot of errors that shouldn't be there. I find it highly unlikely the cable is bad, but its something easy to swap out and change. It may just be a coincidence and the problem hasn't shown itself.

    A side note, when the errors start occurring I am unable to login to pfsense via browser. It pulls up the page but spits out garbage along the top of the screen and it doesn't allow a login.



  • Wouldn't a nice kernel panic be so much more fun than this intermittent failure stuff?


  • Netgate Administrator

    That value at 181 looked extremely bad to me but this seems to indicate it's not that bad:
    http://forum.crucial.com/t5/Solid-State-Drives-SSD/SSD-SMART-quot-Non-4k-Aligned-Access-quot/td-p/43012

    Some attributes seem to be manufacturer specific though. I'd see if you can get a definitive list from Micron (?).

    Steve



  • Yeah - I also saw that some manufacturers throw some weirdness for the 181 value.  I'm not sure why they do that.



  • Checked smart this morning. The 181 value is 214751576065 from 206161510401 yesterday. Larger but not exponentially.

    System shows no odd symptoms this morning.



  • Yeah - I might be inclined to ignore that field for your SSD.

    No increase in UDMA_CRC_Error_Count?



  • UDMA_CRC_Error_Count is the same at 33.

    I will continue to monitor the smart reports daily and report any unusual behavior from the machine.


  • Netgate Administrator

    Here is an explanation of the attributes for your SSD:
    http://code.google.com/p/hddguardian/wiki/Micron_SMART_attributes

    202 - Average lifetime used, seems relevant and your is still at 0% so no worries there.  ;)

    Steve



  • Reporting in on this issue. No crashes since the last one reported in this thread. Total uptime now is 44 days. SMART status looks nominal, with UDMA_CRC_Error_Count still at 33.

    The only odd thing at this point is when looking at the local console of the machine, I am getting "fpudna in kernel mode!" Googling this for pfsense only brings up 2 hits, and in general it seems to bring up issues from 2006-2007 in freebsd and linux. A brief look at some posts seem to indicate it isn't a problem. I still thought it was worth mentioning. If anyone has any idea what that is or means, by all means educate me. ;D Otherwise everything seems normal.

    It would appear to me at this point that it had something to do with the first SATA cable I used. Studying the original cable doesn't reveal any obvious problems, but nothing else has changed so I am assuming that was the cause of all my issues. Hopefully this can remind people when troubleshooting not to overlook cables.


  • Netgate Administrator

    Looks like that error is related to the via padlock driver in 64bit systems. Can you disable padlock? Or switch to 32bit?

    Steve



  • I could switch to a 32bit system, but the error doesn't seem to be causing any issues I have been able to detect. I do have a couple of ipsec tunnels to remote offices which I assume the padlock helps with the encryption. However if the error is indicating that the accelerator features is not working, then there isn't much point to it. CPU usages typically never exceeds 1-2% so I may not even need the hardware crypto. Network performance has been impressive with the VIA dual core, with us typically dealing with ~100mbps UP/DOWN. Granted I don't have a huge amount of users, around 30; but being able to do what I need and with a fanless design with tons of processor to spare is pretty neat.

    I am still running 2.03 and haven't  upgraded to 2.1 yet. Perhaps this will address the fpudna issue. If not, I don't think I am going to worry about it unless there is a pressing reason to.

    I will report any other HDD issues/errors if they happen. I thank everyone for the help and assistance regarding the matter.


Log in to reply