OpenVPN clients not sending broadcast traffic through TAP interface

  • Hi All,

    I've set up a TAP OpenVPN server on pfSense 2.1-RC. Connected remote clients join the network on the same subnet as local clients and can communicate with each other and the local network no problem.

    The main aim of this VPN is to allow each client to send and receive broadcast traffic to/from other connected clients, for games such as Half-Life 2 and Company of Heroes.

    Currently, the only way I've been able to achieve this is by enabling "Force all client generated traffic through the tunnel" which is not desirable, as any downloading/uploading by clients would cripple my connection (think automatic game updates etc).

    Is the routing of broadcast traffic through a secondary network interface something controlled by the OS (all Windows 7) or the game in question, or both? I have tried changing connection metrics in Network Connections > Advanced > Advanced Settings > Adapters and Bindings to no avail.

    How can I configure Windows 7 / OpenVPN to send/receive broadcast traffic?

    Any help or input appreciated!

    Thanks in advance
    ![OpenVPN Server Settings 1.png](/public/imported_attachments/1/OpenVPN Server Settings 1.png)
    ![OpenVPN Server Settings 1.png_thumb](/public/imported_attachments/1/OpenVPN Server Settings 1.png_thumb)
    ![OpenVPN Server Settings 2.png](/public/imported_attachments/1/OpenVPN Server Settings 2.png)
    ![OpenVPN Server Settings 2.png_thumb](/public/imported_attachments/1/OpenVPN Server Settings 2.png_thumb)
    ![OpenVPN Server Settings 3.png](/public/imported_attachments/1/OpenVPN Server Settings 3.png)
    ![OpenVPN Server Settings 3.png_thumb](/public/imported_attachments/1/OpenVPN Server Settings 3.png_thumb)
    ![Firewall - LAN.png](/public/imported_attachments/1/Firewall - LAN.png)
    ![Firewall - LAN.png_thumb](/public/imported_attachments/1/Firewall - LAN.png_thumb)
    ![Firewall - OpenVPN.png](/public/imported_attachments/1/Firewall - OpenVPN.png)
    ![Firewall - OpenVPN.png_thumb](/public/imported_attachments/1/Firewall - OpenVPN.png_thumb)
    ![Firewall - VPN.png](/public/imported_attachments/1/Firewall - VPN.png)
    ![Firewall - VPN.png_thumb](/public/imported_attachments/1/Firewall - VPN.png_thumb)
    ![Firewall - VPNBridge.png](/public/imported_attachments/1/Firewall - VPNBridge.png)
    ![Firewall - VPNBridge.png_thumb](/public/imported_attachments/1/Firewall - VPNBridge.png_thumb)
    ![Interfaces - Assign.png](/public/imported_attachments/1/Interfaces - Assign.png)
    ![Interfaces - Assign.png_thumb](/public/imported_attachments/1/Interfaces - Assign.png_thumb)
    ![Interfaces - Bridges.png](/public/imported_attachments/1/Interfaces - Bridges.png)
    ![Interfaces - Bridges.png_thumb](/public/imported_attachments/1/Interfaces - Bridges.png_thumb)

Log in to reply