Captive Portal not redirecting



  • Hi all,

    I have been trying to use the CP and it was all working fine until the other day when it stopped for no apparent reason.
    The CP is active and I can access it directly by visiting the address but http traffic appears to not be redirected.

    Here is my setup

    pfSense 2.0.3
    NIC1 = Wan1 via Satellite modem
    NIC2 = Wan2 via ADSL router (DG834G), this is only used as a backup for the "Office" network via firewall rules.

    NIC3
    vlan10 = Office, 192.168.1.x DHCP
    vlan20 = Staff, 192.168.2.x DHCP
    vlan30 = Public, 192.168.3.x DHCP

    The only interface which should have the CP enabled is "Public" and previously this has been working.

    There are only 3 firewall rules on "public"

    1. Block access to "Office" subnet
    2. Block access to "Staff" subnet
    3. Allow all other traffic

    The DNS forwarder is active and the DHCP issues an IP in the correct range and sets the DNS as the local IP (192.168.3.1), I have tried disabling DHCP DNS on the wan and setting them manually. I have tried adding all the DNS to the CP allowed IP address but still nothing.

    I had a problem like this when i first set up the box to use dual wan, i thought i made an error so reset config and started again. This would probably solve my problem again but I obviously would rather find the problem rather than keep reseting.

    Any help appreciated.

    Lloyd



  • Try if the DNS setup you have works at all with nslookup from client machine.
    It should be able to resolve IPs.



  • Hi,

    I get:

    Default server: unknown
    Address: 192.168.3.1

    that ip is the correct ip as issued by dhcp



  • Geez…

    Try to resolve a domain name.

    nslookup yahoo.com

    And see if it resolves it to IP.



  • Hi,

    Nslookup yahoo.com

    Server: unknown
    Address: 192.168.3.1

    Non-authoritative answers:
    Name: yahoo.com
    Addresses: 98.139.183.24
    206.190.36.45
    98.138.253.109

    All we pages work, and the DNS appears to be working, any ideas?



  • Try disable and enable Captive service. Of course check on which network interface it's listening to - it should be on your vlan30.



  • Already tried that lots of times and many reboots  :(



  • A reinstall solved whatever problem was there, thanks anyway


Log in to reply