Force youtube over vpn, mostly working just need some help.



  • Hi everyone,

    I have a site-site vpn setup between two pfsense installations. Routing between their LAN subnets works fine (192.168.1.1 - 192.168.2.1) all clients on both sides can talk to each other. I'm trying to force all traffic destined for youtube.com (i'm just using an alias to 74.125.224.1/24 for now) over the vpn tunnel. I've created the firewall rules and traffic appears to be routed to the VPN interface properly when i traceroute youtube.com however the clients are unable to connect to the website and the traceroute dies at the first vpn hop. It seems like the VPN isn't routing the traffic past itself? I'm not really sure how to proceed. Thanks!



  • Firewall rules on OpenVPN at the other end of the link?
    I know that I use rules on site-to-site VPNs to only pass traffic with internal private IP addresses, maybe you have something similar blocking a public IP passed across the VPN.



  • Phil,

    Thanks for the reply. I've looked over the firewall rules and i'm fairly sure there aren't any blocking the traffic.



  • There must be someone else doing this? My ISP's connection to youtube is unusably slow, it would be extremely nice to get this working, i'm sure many others are in the same boat. I've tried everything i can think of, any help would be greatly appreciated.



  • Can you post your routing tables for both ends of the VPN?

    Maybe the traceroute too?



  • It might also be the outbound NAT. Do you use automatic outbound nat or manual?

    If it's manual then you'll need to add a rule for the other network to go through NAT.

    If it's automatic then you might need to switch to manual. Not too sure since I've never really used automatic.



  • @darkcrucible:

    It might also be the outbound NAT. Do you use automatic outbound nat or manual?

    If it's manual then you'll need to add a rule for the other network to go through NAT.

    If it's automatic then you might need to switch to manual. Not too sure since I've never really used automatic.

    Aha! Thank you so much for that suggestions! I just enabled manual outbound NAT on the remote server (the one I would like to route all of my youtube traffic through, and added a rule to pass all traffic from 192.168.1.0/24). Thank you!


Log in to reply