2.1 with IPv6 Tunnel, HELP?



  • @doktornotor:

    You got it misconfigured. HE IPv6 works absolutely fine on tons of boxes here. (On that note, /128 is completely wrong.)

    As I said, I've had this working before. The how-to notes /128 should be correct and if that doesn't work, try /64 - I've also tried /64 without success.

    I believe my OpenVPN interface to StrongVPN may be messing this up. However stopping it doesn't make a difference.



  • Maybe there are some IPV6 related setting that didn't survive an update to 2.1 (assuming you just updated)



  • @kejianshi:

    Maybe there are some IPV6 related setting that didn't survive an update to 2.1 (assuming you just updated)

    This is a new IPV6 configuration. I've had this tunnel working in the past, but not at the same time as my StrongVPN connection. I've deleted the entire IPv6 config and I'm going to re-do it. If that fails, I'm going to rip out the StrongVPN configuration and see if that fixes it.



  • doktornotor knows what he is talking about with IPV6 on these boxes.  I think its his favorite thing to play with.


  • Banned

    As said, tons of people using this. Wipe and redo from scratch. As noted, do NOT use /128. Never seen this howto, if you look at the other one, here's what it says:

    If you use a /128 it will completely break your IPv6 & for me to get it fixed I had to restore a backup & redo all my IPv6 setup. You have been warned.

    (On that note, this one is rather suboptimal as well, no such bridging mess required at all.)



  • As soon as I try to add the GIF interface, I receive this error:

    php: /interfaces_gif_edit.php: The command '/sbin/ifconfig gif0 inet6 2001:470:7:bfd::2 2001:470:7:bfd::1 prefixlen 64 ' returned exit code '1', the output was 'ifconfig: ioctl (SIOCAIFADDR): Invalid argument'

    Same error as this guy perhaps?

    http://forum.pfsense.org/index.php?topic=40377.0


  • Banned

    1/ Wipe everything IPv6 related, incl. the  GIF interface
    2/ Reboot
    3/ Follow this howto. I believe its about the most clear one out there.

    Note: Your IPv4 must be pingable for the tunnel to work.



  • @doktornotor:

    1/ Wipe everything IPv6 related, incl. the  GIF interface
    2/ Reboot
    3/ Follow this howto. I believe its about the most clear one out there.

    Note: Your IPv4 must be pingable for the tunnel to work.

    My IPv4 is pingable. I tested it at GRC.

    I did exactly as you instructed and as soon as I add the GIF interface, I receive this error:

    php: /interfaces_gif_edit.php: The command '/sbin/ifconfig gif0 inet6 2001:470:7:bfd::2 2001:470:7:bfd::1 prefixlen 64 ' returned exit code '1', the output was 'ifconfig: ioctl (SIOCAIFADDR): Invalid argument'

    If I SSH in and type the failing command, I get the same error:

    [2.1-RELEASE][admin@xxx.xxx.xxx]/root(1): /sbin/ifconfig gif0 inet6 2001:470:7:bfd::2 2001:470:7:bfd::1 prefixlen 64
    ifconfig: ioctl (SIOCAIFADDR): Invalid argument

    If I add a / as in the thread I linked, the command works:

    [2.1-RELEASE][admin@xxx.xxx.xxx]/root(2): /sbin/ifconfig gif0 inet6 2001:470:7:bfd::2 2001:470:7:bfd::1 prefixlen /64
    [2.1-RELEASE][admin@xxx.xxx.xxx]/root(3):

    I think this is a problem in the 2.1 release.


  • Banned

    There is no such generic problem for sure. Don't think this is heading anywhere. Do a factory reset, don't think the box configuration is in a sane state.



  • @doktornotor:

    There is no such generic problem for sure. Don't think this is heading anywhere. Do a factory reset, don't think the box configuration is in a sane state.

    The box is in a fine state. I'm looking through the PHP file now. If I can't figure out where the error is in the PHP file I'll just open a support case. We have 5 hours we haven't used.


  • Banned

    Well, as your wish. I have this working on about 10 boxes incl. /48 and multiple /64 subnets on multiple interfaces , I'd sure like hell notice if there was a generic bug making this to not work.



  • @doktornotor:

    Well, as your wish. I have this working on about 10 boxes incl. /48 and multiple /64 subnets on multiple interfaces , I'd sure like hell notice if there was a generic bug making this to not work.

    I'm not doubting you have this working on 10 boxes. I've gotten it working multiple times in the past as well. But have you set this up from scratch on 10 new 2.1 boxes? 2.1 was just released 17 hours ago …

    http://blog.pfsense.org/?p=718


  • Banned

    All of them are running 2.1, and have been running the snapshots for quite some time.



  • @doktornotor:

    All of them are running 2.1, and have been running the snapshots for quite some time.

    The release candidates and the final could have had code changes. Regardless, I've opened a ticket. Hopefully this can be resolved. It seems eerily similar to the thread I linked, especially since if I type the command manually into an SSH shell, it works. If my overall box config were borked, the correct command should fail.

    EDIT:

    Thank you for your help however and also for the link to the how-to. That is a much clearer how-to, the arrows pointing from the HE fields to the pfSense fields make it very easy to follow. I've bookmarked it for future use.


  • Banned

    On a final note here: have you enabled IPv6 at all? It's disabled by default on upgrade from 2.0.x to the 2.1 release.



  • @doktornotor:

    On a final note here: have you enabled IPv6 at all? It's disabled by default on upgrade from 2.0.x to the 2.1 release.

    Damn, I thought you were on to something. "Allow IPv6" was not checked and I did in fact upgrade from 2.0.3 to 2.1. I checked it and tried to add the GIF interface but was met with the same error.

    Should I enable it somewhere else?


  • Banned

    Did you reboot before trying to do anything else? On another note, no idea what got (mis)saved/(mis)configured when you've been trying to add IPv6-related stuff with IPv6 disabled… Leaving this for support, for me reconfiguring the thing from scratch would be faster than messing with box in unknown state.



  • @doktornotor:

    Did you reboot before trying to do anything else? On another note, no idea what got (mis)saved/(mis)configured when you've been trying to add IPv6-related stuff with IPv6 disabled… Leaving this for support, for me reconfiguring the thing from scratch would be faster than messing with box in unknown state.

    Great news.

    Checking "Allow IPv6" has allowed me to figure out what the problem is.

    It's definitely a problem with the GIF GUI interface on 2.1.

    If I try to add a GIF interface via the web GUI, I'm met with that error and it's not actually added. (Even after checking "Allow IPv6")

    If I manually type the command:

    [2.1-RELEASE][admin@xxx.xxx.xxx]/root(1): /sbin/ifconfig gif0 inet6 2001:470:7:bfd::2 2001:470:7:bfd::1 prefixlen /64

    … I am able to add the OPT interface, gateway, and everything works.

    It seems like something in 2.1 is not prefixing a / to the subnet, like the previous thread I linked to.

    Thanks doktornotor, I can proceed and play around with IPv6 while awaiting an official response from support to see if it's something unique to my config, or an actual problem with the 2.1 release.



  • FYI, after typing the correct command into an SSH window, the IPv6 tunnel is up and I can ping ipv6.google.com via the WAN port successfully.

    Ping output:
    PING6(56=40+8+8 bytes) 2001:470:7:bfd::2 –> 2607:f8b0:4004:801::1011
    16 bytes from 2607:f8b0:4004:801::1011, icmp_seq=0 hlim=59 time=10.487 ms
    16 bytes from 2607:f8b0:4004:801::1011, icmp_seq=1 hlim=59 time=10.293 ms
    16 bytes from 2607:f8b0:4004:801::1011, icmp_seq=2 hlim=59 time=14.126 ms

    --- ipv6.l.google.com ping6 statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 10.293/11.635/14.126/1.763 ms

    Doesn't look like there is IPv6 support for AON however, so ultimately I might be out of luck.



  • OK - I'll bite…  AON?



  • OHHHHHHHH - THAT AON!

    ::)

    Why?????



  • For traffic to flow from my LAN clients to the Internet, an additional LAN rule needs to be created for IPv6, as noted in one of doktornotor's links.

    However, his link leaves out a few steps that the official how-to doesn't, so I'm going to submit an update to the official how-to and hopefully combine the two.

    So, in a nutshell, everything is now working - as long as I manually add the / via an SSH command so I'm going to keep my support ticket open.

    Thanks for the help everyone.

    ![9-15-2013 11-20-02 PM.jpg](/public/imported_attachments/1/9-15-2013 11-20-02 PM.jpg)
    ![9-15-2013 11-20-02 PM.jpg_thumb](/public/imported_attachments/1/9-15-2013 11-20-02 PM.jpg_thumb)



  • @kejianshi:

    OHHHHHHHH - THAT AON!

    ::)

    Why?????

    I have my normal WAN connection, but I also keep a nailed-up OpenVPN connection to StrongVPN. I can dynamically route traffic either out via my ISP or via StrongVPN by simply manipulating a LAN firewall rule. For this to work you have to use AON.

    EDIT:

    Why would I do this? My ISP has issues with SIP, so I route my SIP phone over the StrongVPN connection. It's just a tunnel via OpenVPN to bypass my ISPs SIP issues.

    Of course, I can also use it when I'd rather have the StrongVPN IP appear as my source IP rather than my ISPs IP. ;)


  • Banned

    Uhm… considering this is the only mention of IPv6 anywhere on their site, don't see what's the plan there.



  • @doktornotor:

    Uhm… considering this is the only mention of IPv6 anywhere on their site, don't see what's the plan there.

    I don't use them for IPv6, I only route IPv4 over them.

    Basically, they are another gateway, just like Tunnelbroker. So I have 3 gateways - my ISP, StrongVPN, and now HE.net (Tunnelbroker).


  • Banned

    Yes… so what's the IPv6 NAT for?



  • @doktornotor:

    Yes… so what's the IPv6 NAT for?

    Do you mean my previous question about IPv6 and AON?


  • Banned

    Well, you mentioned you need IPv6 NAT on this thread as well…



  • @doktornotor:

    Well, you mentioned you need IPv6 NAT on this thread as well…

    I struck-through (is that even proper grammar?) that comment in my previous post.

    I thought my clients couldn't communicate out via IPv6 because of my AON rules, but it in fact was a simple LAN rule I needed to create, which was mentioned in the how-to link you provided.

    On the LAN tab: IPv6 * LAN net * * * * none

    I now see that your how-to and the official how-to are BOTH missing information, so I'm going to take the correct information from your how-to and see if I can integrate it into the official how-to.


  • Banned

    Ah, OK.



  • @doktornotor:

    Ah, OK.

    Seriously, thank you for your help.

    Hopefully the GIF Interface issue is just something borked on my box, but if not, your guidance helped to narrow it down.



  • FYI, the pfSense guys issued a fix.


  • LAYER 8 Global Moderator

    A fix for what exactly?

    I tried to make heads or talls of this thread a couple of times now – I have been using he tunnel with pfsense for quite some time, all through the development phase, etc..  And don't recall any issues with using the tunnel.

    Now native ipv6 sure - but tunnel has been rock solid..  Still using it - so curious what this fix pfsense issued?  Looking at the commits I don't see anything ipv6 related?



  • @johnpoz:

    A fix for what exactly?

    I tried to make heads or talls of this thread a couple of times now – I have been using he tunnel with pfsense for quite some time, all through the development phase, etc..  And don't recall any issues with using the tunnel.

    Now native ipv6 sure - but tunnel has been rock solid..  Still using it - so curious what this fix pfsense issued?  Looking at the commits I don't see anything ipv6 related?

    They gave me a patch for post #1 in this thread. That resolved my problems.


  • LAYER 8 Global Moderator

    who game you a patch, and where?


Log in to reply