Проблема с Captive portal pfSense 2.1



  • Здравствуйте! Проблема следующая. Настраиваю Captive portal на интефейсе на котором vlan c  dhcp. Пробую самые простые варианты.
    1. Enable captive portal
        No authentication

    Комп ip получает, но интернета нет, странички не доступны, портала страница не вылетает (ос Win 7, брандмауэр выкл, антивирус тоже выкл)

    2.  Enable captive portal
        local user manager / vouchers

    В System -> User Maneger создал пользователя
    Снова комп ip получает, но интернета нет, странички не доступны, портала страница не вылетает
    3.  Enable captive portal
        local user manager / vouchers
        vouchers -> enable vouchers
        создаю ваучеры
    Снова комп ip получает, но интернета нет, странички не доступны, портала страница не вылетает

    Пробовал во всех этих вариантах подкидывать свою страничку, тоже ничего.

    Пару раз появлялась страница портала, даже с одного компа удавалось зайти, второй не хотел заходить.
    Раз появилась моя закинутая страничка, но ничего делать не хотела, посмотрев исходный код страницы в моей в form action стоял ip шлюза vlan с 8000 портом, счелкув по этой ссылке я попал на родную страницу портала, там тоже самое в form action стоял ip шлюза vlan с 8000 портом.
    Смотрел в нете статьи по созданию портала. ничего не нашел интересного….
    Я понимаю, что здесь большой процент кривых моих рук, но может кто поможет дельным советом



  • Здравствуйте,

    Столкнулся с такой же проблеммой. Уже 2−ой день везде лажу, ничего конктретного найти не могу. Как вам удалось настроить портал?

    Спасибо.



  • Логи ?



  • Спасибо за ответ.

    Какие конкретно логи?

    Я тут читал документацию, и говорят, что проблемма в том, что для не авторизированных пользователей не работает DNS. И где−то еще видел упоминание о создание FW правила для портала. Может в этом проблемма?

    У меня чистая инсталяция (pfs 2.1.5, i386), файрвол открыт для ЛАН интерфейса полностью, все работает без портала. Как только включаю портал для ЛАНа (создаю его как написано в можестве постов), не могу подключится никуда. Окошко портала не появляется вообще и браузер выдает конекшн таймаут. Хотя если указываю pass-through адрес, он проходит через портал…

    Может надо какую−то передаресацию вручную сделать? Типа все DNS на 8000 порт? Но как? Насколько я понимаю, портал перехватывает все запросы еще до файрвола



  • Я тут читал документацию, и говорят, что проблемма в том, что для не авторизированных пользователей не работает DNS. И где−то еще видел упоминание о создание FW правила для портала. Может в этом проблемма?

    Есть же возможность в настройках задавать порты, на к-ые CP "не действует". Добавьте 53-ий TCP\UDP и будет вам DNS.
    И в настройках fw тоже (?)



  • a можно подробнее?

    Буду премного благодарен…



  • Все оказалось так просто, что даже обидно…

    При установки портала надо просто в закладке разрешенных IP адресов (Allowed IP addresses) прописать адреса DNS сервера (в моем случае это внешний: 8.8.8.8 и 8.8.4.4).

    И все...

    Почему это нигде не написано? ХЗ....

    ДОПОЛНЕНИЕ.

    На самом деле, если стоят настройки pfSense поумолчанию (а именно, DNS forward включен, и DNS который дается локальным машинам, это IP роутера pfSense), то портал работает как положено.
    У меня проблемма была в том, что на клиентских машинах был прописан статический DNS (8.8.8.8 и 8.8.4.4). Поэтому ничего не работало без разрешения этих DNS. Но как только исправил настройки на клиентах портала (т.е. поставил им IP портала в DNS), то все сразу и заработало как положено по умолчанию (DNS из разрешенных адресов удалил).