Unable to connect LAN over Pfsense using openvpn



  • Hey Guys….

    I am unable to connect my LAN over openvpn. However the open vpn connection is working fine.

    My setup

    INTERNET
        | |
    CISCO Wireless Router 192.168.1.0/24(LAN) & Public IP(WAN)
        | |
    LAN & WIRELESS Connections = server running pfsense/openvpn. 192.168.1.0/24

    I am able to connect to my openvpn server from the internet and getting IP 192.168.255.0/24.

    Please help......



  • Firewall Rules attached No special configuration







  • Banned

    Considering your WAN and LAN are exactly the same… geeez. Try again, complete fail. (On that note, you have the rules there at least 4x more than required.)



  • How about doing a NAT on the WAN side and then using the port forwarding option to connect to open vpn.

    Current setup is

    Internet –-> Cisco Router --->LAN MACHINE running Virtual Machine.
    Public IP --->192.168.1.1  --->192.168.1.128 Nat to 10.0.2.15 on WAN interface on VM and alternate LAN card for LAN access.

    I have 2 physical LAN card on the actual Machine.
    I have checked I have internet access on the VM after doing NAT on WAN interface.

    I am new to pfsense, I really appreciate your responses....

    Regards....


  • LAYER 8 Global Moderator

    What?

    So you have 3 nats before you get to your "lan" of pfsense?  Yeah that is not how you should do it ;)

    Why do you need the cisco router?  What is make and model btw – if its a router, what does it connect into?  Quite possible you have even a 4th nat in this setup...

    Why are you natting to your VM in your vm software?

    Lets start from the beginning -- what are you trying to accomplish exactly?  Do you want your pfsense to be your gateway for just vms or for physical machines as well.  What hardware are you working with modem, router - model numbers.

    I run pfsense on a esxi host, and it is the only NAT between the public internet and my multiple physical networks.



  • I am using Cisco E900 Wireless + LAN router

    I have a dedicated 2mb Wan link with sticky IP connecting to my cisco router over RJ45. Its being NAT(1) to 192.168.1.0/24 and then its bridged with physical LAN to connect Virtual box from where I am getting 192.168.1.114 from Cisco DHCP which is again getting NAT(2) to 10.0.2.15.

    On Cisco I am using port forwarding to the Virtual box i.e 192.168.1.114 and the from Virtual-box its being port forwarded to Pfsense (10.0.2.15).

    My aim is to access the Home network over VPN for security reason otherwise its working fine. I am using this setup cause I don't want to disturb my existing network(Laptops and phones) and also don't want pfsense running all the time. It will be turned on only when I want to connect from outside over the internet.

    If this doesn't work I will put pfsense internet facing and then the Cisco router. I already procured a CPU for the same considering the future requirements.
    Thanks for your response, appreciated…..



  • Take a look at your openvpn firewall rules, and WAN rules.  Lots of redundant rules that are exactly same.  Need to get them down to just 1 unique rule per.


  • LAYER 8 Global Moderator

    I don't understand the point of the virtual box nat?  And then where is the pfsense lan interface connected too?  How are you going to get access to your home lan in this setup?

    Your lan is 192.168.1.0/24 – so your pfsense lan interface is on this network?

    If what your trying to do is just openvpn into your network.. Why are you even running pfsense?  Just run the openvpn server on any box or even its appliance?



  • Thanks for your replies guys , I have changes the configuration and my aim is just to access my home LAN using OPENVPN on PFSENSE.

    Now I have a virtual Machine bridged on the physical network and I am able to connect over OPENVPN . WAN interface is disabled and connecting over the LAN interface only.

    Firewall Rules also modified to any to any.(screenshots attached)

    I am not receiving LAN routes from the VPN connection being established except the below routes.(screenshots)

    OPENVPN cert setting screenshot is also attached.

    LAN network 192.168.1.10/24
    OPENVPN Network 192.168.2.0/24










  • What is the OS of the machine running the VPN client?



  • Windows 7 64bit



  • Got it working , issue was with the services running on the remote client

    Referred to the below doc and bingo….. :)

    http://www.vpntutorials.com/tutorials/openvpn-client-setup-tutorial-for-windows-8/

    Thanks a lot guys for your help.... Really appreciated......



  • Yeah - Normally, thats more of a windows 8 issue.  Glad thats solved.



  • Thanks a lot for your valuable replies, much appreciated….



  • There was another guy on another thread having same issue, so I posted your thread there.


Log in to reply