Can't view computers in Network page on Windows 7, but can connect via IP

  • Hey all. I have a VPN that only allows computers that have OpenVPN installed to connect to. I want to be able to browse other computers in Windows Sharing, and I've followed many guides and played around with the settings, but I can only get IP addresses to work. NetBIOS doesn't seem to work over the VPN, and name resolution of the computers doesn't work either. The computers on their respective LANs can use windows share just fine, so it shouldn't be a windows issue.

    Here are my current settings in pfsense:

    And here is simple drawing of what the network generally looks like:

    If BOB types in \\ he can access the shares on Jacksserver. If Jackthesmack types in \\ he can access the shares on BOB. But typing in \bob, \jacksserver, or \jackthesmack doesn't work (outside the scope of the LAN). Is there something I'm missing? I've been working at this for quite a while.

  • All the way down, bottom of thread.  (possibly),66901.0/topicseen.html

  • I looked at that and it appears he was trying to make his whole LAN environment available through OpenVPN. That is not what I am trying to do. I am trying to have it where the OpenVPN network is explicitly separate, and clients have to actually connect to it. There is no crossover. I have achieved this goal fine, however NetBIOS doesn't appear to be fully functional as I cannot access the computer's via their names, nor can I browse Network in Windows.

  • Do you have a WINs server setup?  Because you will need one.

  • Do clients need to be set up for WINS too? Or will they be able to view the network without any additional software?

  • I stopped using netbios over TCP - I realized its just not needed for me, but my VPNs support it and WINs supports it for the one subnet I wanted to use it for.  For it to work on one subnet and not multiple subnet, you don't need to do all that much.  Just Set up SAMBA on a system somethere in the LAN on a static IP, set it to be master, set WINs option to yes, set OS level high, like 35 or higher.  It should sync up with everything on the network without any fuss.  I also set mine to not require passwords because passwords on shares can be a pain.

Log in to reply