Cannot load mwl driver (kernel provided firmware image doesn't load)



  • Hello,

    I'm trying to get my Netgear WN311T PCI card to work with pfSense 2.1 release (chip Marvell Topdog 8363).
    On boot, i can see the following messages

    mwl0: <marvell 88w8363="">mem 0xf0b10000-0xf0b1ffff,0xf0b00000-0xf0b0ffff irq 16 at device 12.0 on pci17
    mwl0: [ITHREAD]
    mwl0: load mw88W8363fw firmware image (94940 bytes)
    mwl0: unable to setup builtin firmware
    device_attach: mwl0 attach returned 6</marvell>

    I've tried to load a firmware found here : http://files.pfsense.org/jimp/ko-8.3/amd64/mw88W8363fw.ko

    Loaded it with

    kldload -v /boot/firmware/mw88W8363fw.ko
    

    It loads successfully (tested with kldstat) but mwl driver still doesn't work.

    I'm pretty sure that the kernel provided firmware doesn't work, but i don't know a way to force an external firmware (mwlfw_load="YES" doesn't work either).

    Can anyone give me the good direction ?

    Thank you.



  • Try this in loader.conf

    if_mwl_load="YES"

    -LSF



  • Thanks, i've tried, but it doesn't make any difference, same error in dmesg.
    I've also tried mwlfw_load="YES" but it didn't do the trick neither.

    Any other clues i could investigate ?

    Thanks.



  • up  :o
    Been dying trying to find a solution. Please, anyone ?


Log in to reply