Captive portal + ap



  • A ver si me podeis ayudar un poco con mis problemillas del pfsense.
    Para empezar deciros que soy un poco novato en esto. Mi idea es montar un hotspot basado en pfsense. La red que tengo montada seria la siguiente.

    internet–---router(((())))fonera 1------pfsense----fonera 2(((())))clientes wireless
    Decir que "------" significa conexión mediante cable y "(((())))" conexión inhalámbrica

    Caracteristicas de cada conexion:
    router. Ip 192.168.1.1 con el dhcp habilitado y cifrado wep.
    Fonera 1. Con el firmware dd-wrt en modo cliente con ip 192.168.1.5
    pfsense. WAN. Ip hacia internet 192.168.1.250 gateway 192.168.1.1
            LAN. Ip hacia dentro 10.1.2.254 mascara 255.0.0.0 gateway

    Para hacer una comprobación inicial habilito captive portal(creo un usuario con local user manager) y conecto el ordenador con pfsense a un portatil mediante cable. El portatil obtiene ip automaticamente y aqui viene el primero de los problemas, me identifico con el usuario y contraseña creada y funciona pero a medias. El problema es que no salta a la pagina por defecto que he puesto sino que se queda en la pagina de autentificación aunque si pongo ahora otra pagina si va a ella.

    Seguo un paso adenlante;
    Fonera 2. Con firmware dd-wrt en modo ap (creo en modo transparente) con ip 10.1.2.253 y mascara 255.0.0.0 sin habilitar dhcp, wan connection type disable, STP disable, firewall protection SPI disable.

    El tema ahora esta en que me conecto a la señal wireless de la fonera 2, me conecta y me da ip, puedo entrar a configurar la fonera y el pfsense pero en cambio ni me sale la pagina de autentificación y por supuesto no puedo navegar.

    ¿Que podría ir probando?
    Gracias



  • creo tener la respuesta para la segunda pregunta…...
    tienes que configurar la entrada wan de tu fonera de forma estatica asignale una direccion que este dentro de tu red logico la mascara de sub red y la puerta de enlace seria tu pfsense......... ahora en el lado de la lan si la dejas dinamica te vas a conectar de manera positiva y te va a pedir tu usuaruio y contraseña pero si las ip por defectos de tu fonera es distinta a la de la red de igual manera te vas a conectar pero no podras acceder al pfsense...



  • ¡Hola!

    Si sigues con problemas yo probaría la instalación por pasos. Primero sin pfSense, después con pfSense sin portal cautivo y, finalmente, con portal cautivo.

    Intervienen muchas cosas en lo que quieres hacer y es fácil dejarse algo.

    Saludos,

    Josep Pujadas



  • Bueno para lo del primer problema, el error del redireccionamiento de la pagina es que esta debe ir con el http:// o https://


Log in to reply