[SOLUCIONADO] Pfsense 2.1+squid 3.1.x Problemas con Facebook



  • Les platico mi historia, he estado trabajando sobre pfsense 2.1+squid 3.1.x.

    No cache por que es sobre una neoware de bajo consumo de energia, sobre una CF de 4GB, no uso nano por que me limita el tamano de los logs, 1GB RAM.

    Solo filtrado con los ACL's.

    Bien, vean las imagenes que muestro, el problema que me toco vivir era que cuando entraba a FB, la pagina presentaba ciertos problemas:

    A veces no resolvia el nombre, tenia que intentar mas de una vez
    No desplegaba imagenes correctamente
    No podia subir fotos

    Probe esto sobre otra instalacion con 2.0.3 squid 2.7.x sin problemas, use las mismas variables personalizadas:

    log_icp_queries off
    ipcache_size 4096
    fqdncache_size 4096
    memory_pools off
    client_db off
    negative_dns_ttl 30 seconds

    Al parecer todas pasaron sin cambios en la version 3.1.x.

    Revisando que podia ser la causa, localice este parametro que tiene la GUI:

    dns_v4_first

    Cuando lo prendi y salve los cambios, todo volvio a la normalidad.

    Segun leyendo, squid 3.x trata de usar IPv6 primero y si no hay respuesta se va sobre la vieja IPv4, claro que en mi sistema tengo deshabilitado todo el IPv6, no tenia sentido tener esta opcion deshabilitada.

    Les dejo este dato, saludos.









  • Buenas tardes, estoy presentando problemas con el proxy. Hasta hace poco he estado usándolo sin problemas, pero a partir de hoy tengo problemas con algunas imágenes de algunas páginas que no cargan, anteriormente cargaban con normalidad, ahora se queda en negro o si no aparece el símbolo que muestra que la imagen no ha sido encontrada, sin embargo cuando le doy clic derecho y pongo "copiar url de imagen" la muestra en otra ventana. ¿Alguien tiene un idea de que podría ser?



  • Tengo el mismo problema y no sé como entrar a esos parámetros que mencionas, me podrías ayudar?


  • Rebel Alliance

    Creo que el compañero se refiere a que debes "marcar" la opción…. ;)

    ![Proxy server 01.PNG](/public/imported_attachments/1/Proxy server 01.PNG)
    ![Proxy server 01.PNG_thumb](/public/imported_attachments/1/Proxy server 01.PNG_thumb)





  • ¿Versión de tu paquete squid?

    Mira los logs de squid y la ocupación de disco. Puede que tu caché esté teniendo problemas.



  • Como puedo hacer esas consultas? (Ocupación de disco y logs de squid)



  • La ocupación de disco está en la pantalla principal de pfSense.

    Sobre logs de squid, https://forum.pfsense.org/index.php?topic=46513.msg243870#msg243870



  • Saludos Bellera, tengo el mismo problema del amigo Periko, no puedo visualizar bien el contenido de facebook; se visualiza de forma desordenada sin imagenes, tengo instalado

    • PFSense 2.2.4-RELEASE (amd64)
    • Squid3: 0.4.0
    • SquidGuard: 1.9.15

    solicitando su ayuda… requiero de crear grupos con acceso limitado a paginas y otro con acceso a redes sociales, gracias por su respuesta.



  • @victorse:

    se visualiza de forma desordenada sin imagenes

    Cuando un proxy hace eso suele ser que se están filtrando cosas que no deben filtrarse. Hojas de estilo e imágenes.



  • hola

    tengo el mismo problema, pero solo es con facebook, los bancos y otros sitios https funcionan sin problema, el problema es de certificado, si abro la imagen en otra pesta;a gatilla problema de certificado con el sitio de akamaihd

    slds


Log in to reply